summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 09:32:09 +0000
committerAntonio Rojas2021-05-08 09:32:09 +0000
commit6958b71a0fc9f21955b5903b7a754eb37e624d28 (patch)
treec04157ac100948061c89ca7eccce3a7db2f59332
downloadaur-6958b71a0fc9f21955b5903b7a754eb37e624d28.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD61
-rw-r--r--youtube-viewer.install16
3 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..330d22b53c88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = youtube-viewer
+ pkgdesc = Command line utility for viewing YouTube videos
+ pkgver = 3.9.0
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/trizen/youtube-viewer
+ install = youtube-viewer.install
+ arch = any
+ license = GPL3
+ makedepends = perl-module-build
+ depends = perl
+ depends = perl-data-dump
+ depends = perl-file-sharedir
+ depends = perl-json
+ depends = perl-lwp-protocol-https
+ depends = perl-libwww
+ optdepends = mpv: play videos with MPV
+ optdepends = perl-file-sharedir: GTK GUI
+ optdepends = perl-gtk3: GTK3 GUI
+ optdepends = perl-json-xs: faster JSON to HASH conversion
+ optdepends = perl-term-readline-gnu: better STDIN support
+ optdepends = perl-text-charwidth: print results in a fixed-width format
+ optdepends = vlc: play videos with VLC
+ optdepends = wget: download videos with wget
+ optdepends = youtube-dl: play videos with encrypted signatures
+ source = youtube-viewer-3.9.0.tar.gz::https://github.com/trizen/youtube-viewer/archive/3.9.0.tar.gz
+ source = https://github.com/trizen/youtube-viewer/releases/download/3.9.0/youtube-viewer-3.9.0.tar.gz.asc
+ validpgpkeys = ABB8BBAA2E279767774149B7D0A443C703A3A056
+ sha512sums = 7f08823d406a7c97ad1f3daf40d54b8ae282ab9d97df43807e0ad3bf908edcb4e08791e25fc347e949f085e4743b9dcbbfd677ee7a672c2fb498a99626422931
+ sha512sums = SKIP
+
+pkgname = youtube-viewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec9b5717d315
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Ivy Foster <iff@archlinux.org>
+# Contributor: Alad Wenter <alad@mailbox.org>
+# Contributor: Alexander F Rødseth <xyproto@archlinux.org>
+# Contributor: Daniel Wallace < danielwallace at gtmanfred dot com>
+# Contributor: Trizen <echo dHJpemVueEBnbWFpbC5jb20K | base64 -d>
+
+pkgname=youtube-viewer
+pkgdesc='Command line utility for viewing YouTube videos'
+url='https://github.com/trizen/youtube-viewer'
+license=(GPL3)
+epoch=1
+pkgver=3.9.0
+pkgrel=1
+depends=(perl perl-data-dump perl-file-sharedir perl-json perl-lwp-protocol-https perl-libwww)
+makedepends=(perl-module-build)
+optdepends=(
+ 'mpv: play videos with MPV'
+ 'perl-file-sharedir: GTK GUI'
+ 'perl-gtk3: GTK3 GUI'
+ 'perl-json-xs: faster JSON to HASH conversion'
+ 'perl-term-readline-gnu: better STDIN support'
+ 'perl-text-charwidth: print results in a fixed-width format'
+ 'vlc: play videos with VLC'
+ 'wget: download videos with wget'
+ 'youtube-dl: play videos with encrypted signatures'
+)
+arch=(any)
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/trizen/youtube-viewer/archive/$pkgver.tar.gz"
+ "https://github.com/trizen/youtube-viewer/releases/download/$pkgver/youtube-viewer-$pkgver.tar.gz.asc"
+)
+install=youtube-viewer.install
+validpgpkeys=(ABB8BBAA2E279767774149B7D0A443C703A3A056)
+# sums provided by packager makepkg -g
+sha512sums=('7f08823d406a7c97ad1f3daf40d54b8ae282ab9d97df43807e0ad3bf908edcb4e08791e25fc347e949f085e4743b9dcbbfd677ee7a672c2fb498a99626422931'
+ 'SKIP')
+
+build() {
+ cd "youtube-viewer-$pkgver"
+ perl Build.PL --installdirs vendor --gtk
+}
+
+check() {
+ cd "youtube-viewer-$pkgver"
+ ./Build test
+}
+
+package() {
+ cd "youtube-viewer-$pkgver"
+
+ ./Build install --destdir "$pkgdir"
+ rm -r "$pkgdir/usr/lib"
+
+ install -D -m 644 README.md "$pkgdir/usr/share/doc/youtube-viewer/README.md"
+
+ mkdir -p "$pkgdir/usr/share/applications" "$pkgdir/usr/share/pixmaps"
+ mv "$pkgdir/usr/share/perl5/vendor_perl/auto/share/dist/WWW-YoutubeViewer/gtk-youtube-viewer.desktop" \
+ "$pkgdir/usr/share/applications/gtk-youtube-viewer.desktop"
+ cp "$pkgdir/usr/share/perl5/vendor_perl/auto/share/dist/WWW-YoutubeViewer/icons/gtk-youtube-viewer.png" \
+ "$pkgdir/usr/share/pixmaps/gtk-youtube-viewer.png"
+}
diff --git a/youtube-viewer.install b/youtube-viewer.install
new file mode 100644
index 000000000000..fc9060703f48
--- /dev/null
+++ b/youtube-viewer.install
@@ -0,0 +1,16 @@
+post_install() {
+ cat <<EOF
+Because of the increasing popularity of youtube-viewer, the
+developer's API key is occasionally exceeding its usage limit. Users
+who are able are requested to create their own free API keys to reduce
+the load. Please refer to
+
+ /usr/share/doc/youtube-viewer/README.md
+
+for instructions.
+EOF
+}
+
+post_upgrade() {
+ post_install
+}