summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrizen2015-06-17 18:34:08 +0300
committertrizen2015-06-17 18:34:08 +0300
commitfb7810568fec623e2b4330d778cbddf80c146923 (patch)
tree879931ebe3fece3e8256e89ebf3e1ad6f92fc001
downloadaur-fb7810568fec623e2b4330d778cbddf80c146923.tar.gz
Initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD44
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c704adfee261
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = youtube-viewer-git
+ pkgdesc = A command line utility for searching and streaming videos from YouTube.
+ pkgver = 3.1.8.18.g4d2fb32
+ pkgrel = 1
+ url = https://github.com/trizen/youtube-viewer
+ arch = any
+ license = GPLv3
+ makedepends = git
+ depends = perl>=5.16.0
+ depends = perl-data-dump
+ depends = perl-json
+ depends = perl-lwp-protocol-https
+ depends = perl-libwww
+ optdepends = perl-json-xs: faster JSON to HASH conversion
+ optdepends = perl-lwp-useragent-cached: cache support
+ optdepends = perl-text-charwidth: to print the results in a fixed-width format (-W)
+ optdepends = perl-term-readline-gnu: for better STDIN support
+ optdepends = youtube-dl: for playing videos with encrypted signatures
+ optdepends = wget: for downloading videos with wget
+ optdepends = mplayer: for playing the videos with MPlayer
+ optdepends = vlc: for playing the videos with VLC
+ optdepends = mpv: for playing the videos with MPV (recommended)
+ provides = youtube-viewer
+ conflicts = youtube-viewer
+ source = git://github.com/trizen/youtube-viewer.git
+ md5sums = SKIP
+
+pkgname = youtube-viewer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bc040f9da8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Trizen <echo dHJpemVueEBnbWFpbC5jb20K | base64 -d>
+
+_pkgname=youtube-viewer
+pkgname=youtube-viewer-git
+pkgver=3.1.8.18.g4d2fb32
+pkgrel=1
+pkgdesc="A command line utility for searching and streaming videos from YouTube."
+arch=('any')
+url="https://github.com/trizen/youtube-viewer"
+license=('GPLv3')
+makedepends=('git')
+
+provides=('youtube-viewer')
+conflicts=('youtube-viewer')
+
+depends=('perl>=5.16.0' 'perl-data-dump' 'perl-json' 'perl-lwp-protocol-https' 'perl-libwww')
+
+optdepends=(
+ 'perl-json-xs: faster JSON to HASH conversion'
+ 'perl-lwp-useragent-cached: cache support'
+ 'perl-text-charwidth: to print the results in a fixed-width format (-W)'
+ 'perl-term-readline-gnu: for better STDIN support'
+ 'youtube-dl: for playing videos with encrypted signatures'
+ 'wget: for downloading videos with wget'
+ 'mplayer: for playing the videos with MPlayer'
+ 'vlc: for playing the videos with VLC'
+ 'mpv: for playing the videos with MPV (recommended)'
+ )
+
+source=('git://github.com/trizen/youtube-viewer.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --always | sed -e 's|-|.|g'
+}
+
+package() {
+ cd $_pkgname
+ perl Build.PL --destdir "$pkgdir" --installdirs vendor
+ ./Build
+ ./Build test
+ ./Build install --install_path script=/usr/bin
+}