summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2018-04-28 04:04:12 -0600
committerBrian Bidulock2018-04-28 04:04:12 -0600
commit94866aea7f94757b30844fc66d9b4844e961bcf4 (patch)
tree54e39a6c98f2b8723b7b5d6f06fab08175d579b5
parenta43562abeab36044f06be37cd04c536b97b0a447 (diff)
downloadaur-94866aea7f94757b30844fc66d9b4844e961bcf4.tar.gz
libnsl version of ypbind
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD54
-rw-r--r--fixes.patch24
-rw-r--r--ypbind.conf1
4 files changed, 68 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 42a9f98872fd..0aae8e133f90 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,26 @@
pkgbase = ypbind-mt
pkgdesc = Linux NIS daemon
- pkgver = 1.38
+ pkgver = 2.4
pkgrel = 1
- url = http://www.linux-nis.org/nis/ypbind-mt/
+ url = https://github.com/thkukuk/ypbind-mt
arch = i686
arch = x86_64
license = GPL2
- makedepends = networkmanager
- depends = rpcbind
- depends = openslp
+ makedepends = libxslt
+ makedepends = libxml2
+ makedepends = docbook-xml
+ makedepends = docbook-xsl
depends = yp-tools
- depends = systemd
+ depends = libsystemd
backup = etc/yp.conf
- source = http://www.linux-nis.org/download/ypbind-mt/ypbind-mt-1.38.tar.bz2
+ source = https://github.com/thkukuk/ypbind-mt/archive/ypbind-mt-2.4.tar.gz
source = ypbind.service
- md5sums = 094088c0e282fa7f3b3dd6cc51d0a4e1
+ source = ypbind.conf
+ source = fixes.patch
+ md5sums = 11f09789cc8bb4d844798c3535c30208
md5sums = 5ea205756731c2978cca4934141424bd
+ md5sums = ae60a6c4d033017fad861fcb9194dbc5
+ md5sums = 17374b15cfa85bae36ee1948600821e6
pkgname = ypbind-mt
diff --git a/PKGBUILD b/PKGBUILD
index 6843110e0a1f..a7852ec27979 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,46 @@
-# $Id: PKGBUILD 259084 2016-02-12 01:37:04Z dreisner $
-# Maintainer: Tom Gundersen <teg@jklm.no>
+# vim: set et sw=2:
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Tom Gundersen <teg@jklm.no>
# Contributor: Gaetan Bisson <bisson@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=ypbind-mt
-pkgver=1.38
+pkgver=2.4
pkgrel=1
pkgdesc='Linux NIS daemon'
-url='http://www.linux-nis.org/nis/ypbind-mt/'
+url='https://github.com/thkukuk/ypbind-mt'
license=('GPL2')
arch=('i686' 'x86_64')
-makedepends=('networkmanager')
-depends=('rpcbind' 'openslp' 'yp-tools' 'systemd')
+makedepends=('libxslt' 'libxml2' 'docbook-xml' 'docbook-xsl')
+depends=('yp-tools' 'libsystemd')
backup=('etc/yp.conf')
-source=("http://www.linux-nis.org/download/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
- 'ypbind.service')
-md5sums=('094088c0e282fa7f3b3dd6cc51d0a4e1'
- '5ea205756731c2978cca4934141424bd')
+source=("$url/archive/$pkgname-$pkgver.tar.gz"
+ 'ypbind.service'
+ 'ypbind.conf'
+ 'fixes.patch')
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- ./configure \
- --prefix=/usr \
- --sbindir=/usr/bin
+prepare() {
+ cd $pkgname-$pkgname-$pkgver
+ patch -Np2 -b -z .orig <../fixes.patch
+ ./autogen.sh
+}
- make
+build() {
+ cd $pkgname-$pkgname-$pkgver
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make V=0
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- make DESTDIR="${pkgdir}" install
-
- install -D -m644 etc/yp.conf "${pkgdir}"/etc/yp.conf
- install -D -m644 ../ypbind.service "${pkgdir}"/usr/lib/systemd/system/ypbind.service
- install -d -m755 "${pkgdir}"/var/yp/binding
+ cd $pkgname-$pkgname-$pkgver
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 etc/yp.conf "${pkgdir}"/etc/yp.conf
+ install -D -m644 ../ypbind.service "${pkgdir}"/usr/lib/systemd/system/ypbind.service
+ install -D -m644 ../ypbind.conf "${pkgdir}"/usr/lib/tmpfiles.d/ypbind.conf
}
+
+md5sums=('11f09789cc8bb4d844798c3535c30208'
+ '5ea205756731c2978cca4934141424bd'
+ 'ae60a6c4d033017fad861fcb9194dbc5'
+ '17374b15cfa85bae36ee1948600821e6')
diff --git a/fixes.patch b/fixes.patch
new file mode 100644
index 000000000000..e9a53f717e6f
--- /dev/null
+++ b/fixes.patch
@@ -0,0 +1,24 @@
+diff -up src/ypbind-mt-ypbind-mt-2.4/configure.ac.orig src/ypbind-mt-ypbind-mt-2.4/configure.ac
+--- src/ypbind-mt-ypbind-mt-2.4/configure.ac.orig 2016-03-02 07:12:27.000000000 -0700
++++ src/ypbind-mt-ypbind-mt-2.4/configure.ac 2018-04-28 03:27:33.000000000 -0600
+@@ -26,7 +26,7 @@ AC_CHECK_LIB(pthread, pthread_create)
+
+ PKG_CHECK_MODULES([SYSTEMD], [libsystemd >= 209], [USE_SD_NOTIFY=1], [USE_SD_NOTIFY=0])
+ AC_SUBST(USE_SD_NOTIFY)
+-#PKG_CHECK_MODULES([NSL], [libnsl], [], [AC_CHECK_LIB([nsl],[yp_match],[LIBNSL_LIBS="-lnsl"],[LIBNSL_LIBS=""])])
++#PKG_CHECK_MODULES([NSL], [libnsl], [], [AC_CHECK_LIB([nsl],[yp_match],[NSL_LIBS="-lnsl"],[NSL_LIBS=""])])
+ PKG_CHECK_MODULES([NSL], [libnsl])
+ PKG_CHECK_MODULES([TIRPC], [libtirpc], [], [TIRPC_LIBS=""])
+ if test -n "$TIRPC_LIBS"; then
+diff -up src/ypbind-mt-ypbind-mt-2.4/src/ypbind-mt.c.orig src/ypbind-mt-ypbind-mt-2.4/src/ypbind-mt.c
+--- src/ypbind-mt-ypbind-mt-2.4/src/ypbind-mt.c.orig 2018-04-28 03:28:56.000000000 -0600
++++ src/ypbind-mt-ypbind-mt-2.4/src/ypbind-mt.c 2018-04-28 03:29:49.000000000 -0600
+@@ -278,7 +278,7 @@ create_pidfile (void)
+ struct flock lock;
+ int left, written;
+ pid_t pid;
+- char pbuf[10], *ptr;
++ char pbuf[14], *ptr;
+ int flags;
+
+ lock_fd = open (_YPBIND_PIDFILE, O_CREAT | O_RDWR,
diff --git a/ypbind.conf b/ypbind.conf
new file mode 100644
index 000000000000..e0533e348aa3
--- /dev/null
+++ b/ypbind.conf
@@ -0,0 +1 @@
+d /var/yp/binding 0755 - - -