summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-07-06 19:22:03 +0000
committerAntonio Rojas2017-07-06 19:22:03 +0000
commita43562abeab36044f06be37cd04c536b97b0a447 (patch)
treea6725ec8d7ef2003ac4d883e4062bff4bc60e584
downloadaur-a43562abeab36044f06be37cd04c536b97b0a447.tar.gz
Drop from repos
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
-rw-r--r--nisdomainname.conf4
-rw-r--r--ypbind.service16
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42a9f98872fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ypbind-mt
+ pkgdesc = Linux NIS daemon
+ pkgver = 1.38
+ pkgrel = 1
+ url = http://www.linux-nis.org/nis/ypbind-mt/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = networkmanager
+ depends = rpcbind
+ depends = openslp
+ depends = yp-tools
+ depends = systemd
+ backup = etc/yp.conf
+ source = http://www.linux-nis.org/download/ypbind-mt/ypbind-mt-1.38.tar.bz2
+ source = ypbind.service
+ md5sums = 094088c0e282fa7f3b3dd6cc51d0a4e1
+ md5sums = 5ea205756731c2978cca4934141424bd
+
+pkgname = ypbind-mt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6843110e0a1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 259084 2016-02-12 01:37:04Z dreisner $
+# Maintainer: Tom Gundersen <teg@jklm.no>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
+
+pkgname=ypbind-mt
+pkgver=1.38
+pkgrel=1
+pkgdesc='Linux NIS daemon'
+url='http://www.linux-nis.org/nis/ypbind-mt/'
+license=('GPL2')
+arch=('i686' 'x86_64')
+makedepends=('networkmanager')
+depends=('rpcbind' 'openslp' 'yp-tools' 'systemd')
+backup=('etc/yp.conf')
+source=("http://www.linux-nis.org/download/${pkgname}/${pkgname}-${pkgver}.tar.bz2"
+ 'ypbind.service')
+md5sums=('094088c0e282fa7f3b3dd6cc51d0a4e1'
+ '5ea205756731c2978cca4934141424bd')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --sbindir=/usr/bin
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ install -D -m644 etc/yp.conf "${pkgdir}"/etc/yp.conf
+ install -D -m644 ../ypbind.service "${pkgdir}"/usr/lib/systemd/system/ypbind.service
+ install -d -m755 "${pkgdir}"/var/yp/binding
+}
diff --git a/nisdomainname.conf b/nisdomainname.conf
new file mode 100644
index 000000000000..bbbbf8fc72b6
--- /dev/null
+++ b/nisdomainname.conf
@@ -0,0 +1,4 @@
+#
+# NIS domain to be set in /etc/rc.d/ypbind
+#
+NISDOMAINNAME=""
diff --git a/ypbind.service b/ypbind.service
new file mode 100644
index 000000000000..bb13f1d66560
--- /dev/null
+++ b/ypbind.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=YP Bind
+Requires=rpcbind.service domainname.service
+After=rpcbind.service domainname.service network.target
+Before=systemd-user-sessions.service
+
+[Service]
+Type=forking
+PIDFile=/run/ypbind.pid
+ExecStart=/usr/bin/ypbind
+# Terrible hack, upstream ypbind should sort something out
+# Wait for at most 10 seconds for a NIS master to become available
+ExecStartPost=/bin/sh -c "for i in 1 2 3 4 5 6 7 8 9 10; do ypwhich && break; sleep 1; done"
+
+[Install]
+WantedBy=multi-user.target