summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authore5ten2018-10-27 22:55:02 -0400
committere5ten2018-10-27 22:55:02 -0400
commit70403632e6c0fd3c77fa9cf2b500cd40c90dad48 (patch)
treea9837746e0ca9c7fe016df8ce5f4f084525168f0
downloadaur-70403632e6c0fd3c77fa9cf2b500cd40c90dad48.tar.gz
initial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..227e8efb6521
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = yq-bin
+ pkgdesc = yq is a portable command-line YAML processor
+ pkgver = 2.1.2
+ pkgrel = 1
+ url = https://github.com/mikefarah/yq
+ arch = x86_64
+ license = MIT
+ provides = yq
+ conflicts = yq
+ source = https://github.com/mikefarah/yq/releases/download/2.1.2/yq_linux_amd64
+ sha512sums = d43a5469b4df7734b5f943cf3d88a23d94f83d72cbff64694564c4bb56a52cf78c3a2e8a4e976f3572a5a9de84c4b060f77964d932a018b0ab2cf4a8a34e8e10
+
+pkgname = yq-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2810fe4174c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: E5ten <e5ten.arch@gmail.com>
+
+pkgname=yq-bin
+pkgver=2.1.2
+pkgrel=1
+pkgdesc='yq is a portable command-line YAML processor'
+arch=('x86_64')
+url='https://github.com/mikefarah/yq'
+license=('MIT')
+provides=('yq')
+conflicts=('yq')
+source=('https://github.com/mikefarah/yq/releases/download/2.1.2/yq_linux_amd64')
+sha512sums=('d43a5469b4df7734b5f943cf3d88a23d94f83d72cbff64694564c4bb56a52cf78c3a2e8a4e976f3572a5a9de84c4b060f77964d932a018b0ab2cf4a8a34e8e10')
+
+package() {
+ install -Dm755 $srcdir/yq_linux_amd64 $pkgdir/usr/bin/yq
+}
+