summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew McGinn2020-02-21 11:34:18 -0500
committerMatthew McGinn2020-02-21 11:34:18 -0500
commit4d98a5617c79677d5ffb845226867d9377ce1ada (patch)
treecb0e1dfb37e57568b32226061b3bf4ce33ff4a0c
downloadaur-4d98a5617c79677d5ffb845226867d9377ce1ada.tar.gz
initial commit to bring package back
Signed-off-by: Matthew McGinn <mamcgi@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7eb520a45e47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = yq2-bin
+ pkgdesc = a portable command-line YAML processor
+ pkgver = 3.1.2
+ pkgrel = 1
+ url = https://github.com/mikefarah/yq
+ arch = x86_64
+ license = MIT
+ provides = yq
+ conflicts = yq
+ source = yq-3.1.2::https://github.com/mikefarah/yq/releases/download/3.1.2/yq_linux_amd64
+ sha256sums = 7c5a5a3b752c869b0054343307b117490b884131a564e64100a456863c5b604f
+
+pkgname = yq2-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b179dd8f2df9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Matthew McGinn <mamcgi@gmail.com>
+# Contributor: E5ten <e5ten.arch@gmail.com>
+
+pkgname=yq2-bin
+pkgver=3.1.2
+pkgrel=1
+pkgdesc='a portable command-line YAML processor'
+arch=('x86_64')
+url='https://github.com/mikefarah/yq'
+_github_url="https://github.com/mikefarah/yq"
+license=('MIT')
+provides=('yq')
+conflicts=('yq')
+source=("yq-${pkgver}::https://github.com/mikefarah/yq/releases/download/${pkgver}/yq_linux_amd64")
+sha256sums=('7c5a5a3b752c869b0054343307b117490b884131a564e64100a456863c5b604f')
+
+package() {
+ install -Dm755 "${srcdir}/yq-${pkgver}" "${pkgdir}/usr/bin/yq"
+}