summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Haubner2020-02-03 23:43:38 +0100
committerAnton Haubner2020-02-03 23:43:38 +0100
commitbd94ef57ca4e78d43eec5f2ef7cd23d419299ec4 (patch)
tree0b3a5035f549342a410dda0ff83f395f207a74e3
downloadaur-bd94ef57ca4e78d43eec5f2ef7cd23d419299ec4.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..017215534506
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = yt-bin
+ pkgdesc = Youtube Terminal UI for music streaming. WIP.
+ pkgver = r23.1f04565
+ pkgrel = 1
+ arch = x86_64
+ license = GPL3
+ depends = ncurses>=6.1
+ depends = mpv>=1:0.32.0
+ provides = yt
+ source = https://ahbnr.de/jenkins/job/yt/13/artifact/yt
+ source = https://ahbnr.de/jenkins/job/yt/13/artifact/version
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = yt-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..37045df66ce1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: ahbnr <anton dot haubner at outlook dot de>
+
+pkgname=yt-bin
+pkgver=r23.1f04565
+pkgrel=1
+pkgdesc="Youtube Terminal UI for music streaming. WIP."
+arch=('x86_64')
+license=('GPL3')
+depends=('ncurses>=6.1' 'mpv>=1:0.32.0')
+makedepends=()
+replaces=()
+conflicts=()
+provides=('yt')
+backup=()
+options=()
+install=
+source=('https://ahbnr.de/jenkins/job/yt/13/artifact/yt' 'https://ahbnr.de/jenkins/job/yt/13/artifact/version')
+noextract=()
+md5sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cat "$srcdir/version"
+}
+
+build() {
+ chmod +x "$srcdir/yt"
+}
+
+package() {
+ binary="yt"
+
+ strip -s "${binary}"
+
+ mkdir -p "$pkgdir/usr/bin"
+ cp "${binary}" "$pkgdir/usr/bin"
+}