summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2022-03-06 09:18:09 +0000
committerGr3q2022-03-06 09:18:09 +0000
commit3e8eab6766f9cb2db68142d72ce48f8949591a2c (patch)
treed1a51038227c13c36def111ac17b81b6dff8f164
parent9be3a31503b6e6baf1139b9b15e4fe848b2d7a7a (diff)
downloadaur-3e8eab6766f9cb2db68142d72ce48f8949591a2c.tar.gz
stop using deprecated build and install methods
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e375caeaddd4..c518977c1a3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = yt-dlg
pkgdesc = A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)
pkgver = 1.8.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/oleksis/youtube-dl-gui
arch = any
license = custom:UNLICENSE
- makedepends = git
makedepends = python-polib
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python-pypubsub
depends = python-wxpython
diff --git a/PKGBUILD b/PKGBUILD
index f60e5328ff4e..412caa314180 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=yt-dlg
pkgname=$_pkgname
pkgver=1.8.3
-pkgrel=1
+pkgrel=2
pkgdesc="A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)"
arch=('any')
url="https://github.com/oleksis/youtube-dl-gui"
@@ -15,17 +15,29 @@ depends=(
)
optdepends=('ffmpeg: convert video files to audio-only files'
'youtube-dl: alternative to the youtube-dl program downloaded by yt-dlg')
-makedepends=('git' 'python-polib' 'python-setuptools')
+makedepends=(
+ 'python-polib'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-setuptools'
+)
provides=($_pkgname)
conflicts=($_pkgname youtube-dl-gui)
source=(https://github.com/oleksis/youtube-dl-gui/archive/refs/tags/v"${pkgver}".tar.gz)
sha512sums=('f56adb25baea489f21a57a5513d95e656835429b4512e49d848076afaa60fa356d3468cd5460fcc6e6f311bf605d959a78b4277a0ab272903dde25c2cc87ca8e')
+
+build() {
+ cd youtube-dl-gui-"${pkgver}"
+ python setup.py build_trans
+ python -m build --wheel --no-isolation
+}
+
package() {
cd youtube-dl-gui-"${pkgver}"
install -Dm644 yt-dlg.desktop "$pkgdir/usr/share/applications/yt-dlg.desktop"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python setup.py build_trans install --root="$pkgdir" --optimize=1
-}
-
+ python -m installer --destdir="$pkgdir" dist/*.whl
+} \ No newline at end of file