summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2021-11-06 11:30:47 +0000
committerGr3q2021-11-06 11:30:47 +0000
commit5c8c9406851595a7cc98daab769d5fd65faaaa7c (patch)
tree2668e3890751956707437cf29adfe29dfe86eb04
downloadaur-5c8c9406851595a7cc98daab769d5fd65faaaa7c.tar.gz
Add new package
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a21bf827c760
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = yt-dlg
+ pkgdesc = A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)
+ pkgver = 1.8.1
+ pkgrel = 1
+ url = https://github.com/oleksis/youtube-dl-gui
+ arch = any
+ license = custom:UNLICENSE
+ makedepends = git
+ makedepends = python-polib
+ makedepends = python-setuptools
+ depends = python-pypubsub
+ depends = python-wxpython
+ depends = xdg-utils
+ optdepends = ffmpeg: convert video files to audio-only files
+ optdepends = youtube-dl: alternative to the youtube-dl program downloaded by yt-dlg
+ provides = yt-dlg
+ conflicts = yt-dlg
+ conflicts = youtube-dl-gui
+ source = https://github.com/oleksis/youtube-dl-gui/archive/refs/tags/v1.8.1.tar.gz
+ sha512sums = 0871f1944e9a81570f02c040d43f6dd06c883f27451d57b697f277a9be0fb21655c757bcbe961a04ed16e9329f3502cbe740d7734842a0031af9bb3156d7fbc7
+
+pkgname = yt-dlg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1fa9e3171cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Gr3q <floyd0122@gmail.com>
+
+_pkgname=yt-dlg
+pkgname=$_pkgname
+pkgver=1.8.1
+pkgrel=1
+pkgdesc="A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)"
+arch=('any')
+url="https://github.com/oleksis/youtube-dl-gui"
+license=('custom:UNLICENSE')
+depends=(
+ 'python-pypubsub'
+ 'python-wxpython'
+ 'xdg-utils'
+)
+optdepends=('ffmpeg: convert video files to audio-only files'
+ 'youtube-dl: alternative to the youtube-dl program downloaded by yt-dlg')
+makedepends=('git' 'python-polib' 'python-setuptools')
+provides=($_pkgname)
+conflicts=($_pkgname youtube-dl-gui)
+source=(https://github.com/oleksis/youtube-dl-gui/archive/refs/tags/v"${pkgver}".tar.gz)
+sha512sums=('0871f1944e9a81570f02c040d43f6dd06c883f27451d57b697f277a9be0fb21655c757bcbe961a04ed16e9329f3502cbe740d7734842a0031af9bb3156d7fbc7')
+
+package() {
+ cd youtube-dl-gui-"${pkgver}"
+ install -Dm644 yt-dlg.desktop "$pkgdir/usr/share/applications/yt-dlg.desktop"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python setup.py build_trans install --root="$pkgdir" --optimize=1
+}
+