summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2021-07-12 18:52:30 +0100
committerGr3q2021-07-12 18:52:30 +0100
commit346bc70b63535f8105a485ca546f9dcdf385a7dc (patch)
tree12a7659df0f55d65c9ee6c4c7ea71ed78432912c
parent3fd9bea8128bd618751e1c11de941533b3ea6c5e (diff)
downloadaur-346bc70b63535f8105a485ca546f9dcdf385a7dc.tar.gz
Update to use provided .application file
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b5c4b6cc5fa..f11bd34a5677 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yt-dlg-git
pkgdesc = A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)
- pkgver = 1.2.0.r124.g8dbf054
- pkgrel = 4
+ pkgver = 1.2.0.r127.g9789d97
+ pkgrel = 1
url = https://github.com/oleksis/youtube-dl-gui
arch = any
license = custom:UNLICENSE
@@ -15,8 +15,6 @@ pkgbase = yt-dlg-git
conflicts = yt-dlg
conflicts = youtube-dl-gui
source = yt-dlg-git::git+https://github.com/yt-dlg/yt-dlg.git
- source = yt-dlg.desktop
sha256sums = SKIP
- sha256sums = c0b27a97791951beafdc98fc7fc4580092a318aa49aef56bd338ed490cc7b574
pkgname = yt-dlg-git
diff --git a/PKGBUILD b/PKGBUILD
index 8dc4d7a8cfdf..f646b876c368 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=yt-dlg
pkgname=$_pkgname-git
-pkgver=1.2.0.r124.g8dbf054
-pkgrel=4
+pkgver=1.2.0.r127.g9789d97
+pkgrel=1
pkgdesc="A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)"
arch=('any')
url="https://github.com/oleksis/youtube-dl-gui"
@@ -18,19 +18,17 @@ optdepends=('ffmpeg: convert video files to audio-only files'
makedepends=('git')
provides=($_pkgname)
conflicts=($_pkgname youtube-dl-gui)
-source=($pkgname::git+https://github.com/yt-dlg/yt-dlg.git
- yt-dlg.desktop)
-sha256sums=('SKIP'
- 'c0b27a97791951beafdc98fc7fc4580092a318aa49aef56bd338ed490cc7b574')
+source=($pkgname::git+https://github.com/yt-dlg/yt-dlg.git)
+sha256sums=('SKIP')
pkgver() {
git -C $pkgname describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
+ cd $pkgname
install -Dm644 yt-dlg.desktop "$pkgdir/usr/share/applications/yt-dlg.desktop"
- cd $pkgname
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
python setup.py build_trans install --root="$pkgdir" --optimize=1
}