summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2021-07-03 10:04:51 +0100
committerGr3q2021-07-03 10:04:51 +0100
commit9015ab16d04323de352dd8d5230f85444ca76aec (patch)
treee8855bd16ed0b94f10c23768fba9d3e8ea63e0df
parent8a19efd550d3c5f2ebea6368f893dcd52845a714 (diff)
downloadaur-9015ab16d04323de352dd8d5230f85444ca76aec.tar.gz
Update .SRCINFO and PKGBUILD with the correct url and deps
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41e8b801a72a..55d9f0f47af6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,15 +2,12 @@ pkgbase = yt-dlg-git
pkgdesc = A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)
pkgver = v1.2.0.r124.g8dbf054
pkgrel = 1
- url = https://github.com/MrS0m30n3/youtube-dl-gui
+ url = https://github.com/oleksis/youtube-dl-gui
arch = any
license = custom:UNLICENSE
makedepends = git
- depends = gtk-update-icon-cache
depends = python-pypubsub
depends = python-wxpython
- depends = libtiff
- depends = libjpeg-turbo
optdepends = ffmpeg: convert video files to audio-only files
optdepends = youtube-dl: alternative to the youtube-dl program downloaded by yt-dlg
provides = yt-dlg
diff --git a/PKGBUILD b/PKGBUILD
index e6a83f91dd73..efad79006a87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,11 @@ pkgver=v1.2.0.r124.g8dbf054
pkgrel=1
pkgdesc="A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)"
arch=('any')
-url="https://github.com/MrS0m30n3/youtube-dl-gui"
+url="https://github.com/oleksis/youtube-dl-gui"
license=('custom:UNLICENSE')
depends=(
- 'gtk-update-icon-cache'
'python-pypubsub'
'python-wxpython'
- 'libtiff'
- 'libjpeg-turbo'
)
optdepends=('ffmpeg: convert video files to audio-only files'
'youtube-dl: alternative to the youtube-dl program downloaded by yt-dlg')
@@ -30,12 +27,16 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
++build() {
+ cd $pkgname
+ python setup.py build_trans
+}
+
package() {
install -Dm644 yt-dlg.desktop "$pkgdir/usr/share/applications/yt-dlg.desktop"
cd $pkgname
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python setup.py build_trans
python setup.py install --root="$pkgdir" --optimize=1
}