summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGr3q2022-03-06 09:18:43 +0000
committerGr3q2022-03-06 09:18:43 +0000
commitc57404f7449365e78d84ac86fa5362b14d359631 (patch)
tree24178032b35bf3fe8272a1beffcc913c8432bf0f
parentdc5d382b1d914b929aee66a4ae0668ddb750c610 (diff)
downloadaur-c57404f7449365e78d84ac86fa5362b14d359631.tar.gz
stop using deprecated build and install methods
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fe1f5ea7ea8..05758fae0f5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yt-dlg-git
pkgdesc = A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)
- pkgver = 1.2.0.r150.g4ac8184
+ pkgver = 1.2.0.r238.gf0fe39e
pkgrel = 1
url = https://github.com/oleksis/youtube-dl-gui
arch = any
@@ -8,6 +8,8 @@ pkgbase = yt-dlg-git
makedepends = git
makedepends = python-polib
makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
depends = python-pypubsub
depends = python-wxpython
depends = xdg-utils
diff --git a/PKGBUILD b/PKGBUILD
index 966327b19797..96bf7bfd6fe8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=yt-dlg
pkgname=$_pkgname-git
-pkgver=1.2.0.r150.g4ac8184
+pkgver=1.2.0.r238.gf0fe39e
pkgrel=1
pkgdesc="A cross platform front-end GUI of the popular youtube-dl written in wxPython (maintained fork of youtube-dl-gui)"
arch=('any')
@@ -15,7 +15,13 @@ depends=(
)
optdepends=('ffmpeg: convert video files to audio-only files'
'youtube-dl: alternative to the youtube-dl program downloaded by yt-dlg')
-makedepends=('git' 'python-polib' 'python-setuptools')
+makedepends=(
+ 'git'
+ 'python-polib'
+ 'python-setuptools'
+ 'python-build'
+ 'python-installer'
+)
provides=($_pkgname)
conflicts=($_pkgname youtube-dl-gui)
source=($pkgname::git+https://github.com/yt-dlg/yt-dlg.git)
@@ -25,11 +31,17 @@ pkgver() {
git -C $pkgname describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd $pkgname
+ python setup.py build_trans
+ python -m build --wheel --no-isolation
+}
+
package() {
cd $pkgname
install -Dm644 yt-dlg.desktop "$pkgdir/usr/share/applications/yt-dlg.desktop"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- python setup.py build_trans install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}