summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormezcal2015-07-16 10:56:14 +0200
committermezcal2015-07-16 10:56:14 +0200
commit594d2a976c0ae8e6558fec8efae1b97006327398 (patch)
tree1209ab3e387204d95ab248510415431406e8f004
downloadaur-594d2a976c0ae8e6558fec8efae1b97006327398.tar.gz
Package imported from AUR3
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rwxr-xr-xytd19
-rw-r--r--ytd.desktop14
-rw-r--r--ytd.install3
-rw-r--r--ytd.xml69
6 files changed, 160 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76221d54f079
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ytd
+ pkgdesc = an utility for downloading multimedia content from YouTube and other online streaming services.
+ pkgver = 1.49
+ pkgrel = 1
+ url = http://www.pepak.net/download/youtube-downloader/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = wine
+ source = ytd
+ source = ytd.desktop
+ source = ytd.xml
+ source = http://www.pepak.net/files/youtube/ytd-1.49.zip
+ md5sums = fa41961f5092fa471145ade79584fd4b
+ md5sums = e10bfe126777f969da9eaf35edd0ba65
+ md5sums = ef7d9adbc174a208bf01300b6ab4f8bd
+ md5sums = 09b3f080b1d94e67232be1bf01ffe1d3
+
+pkgname = ytd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0eac61d63bf4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Filip <fila pruda com>
+pkgname=ytd
+pkgver=1.49
+pkgrel=1
+pkgdesc="an utility for downloading multimedia content from YouTube and other online streaming services."
+arch=('i686' 'x86_64')
+url="http://www.pepak.net/download/youtube-downloader/"
+license=('GPL')
+depends=(wine)
+makedepends=()
+source=(ytd ytd.desktop ytd.xml http://www.pepak.net/files/youtube/ytd-$pkgver.zip)
+md5sums=(
+ 'fa41961f5092fa471145ade79584fd4b' 'e10bfe126777f969da9eaf35edd0ba65'
+ 'ef7d9adbc174a208bf01300b6ab4f8bd' '09b3f080b1d94e67232be1bf01ffe1d3')
+
+package() {
+
+ #bin
+ install -Dm755 ytd "$pkgdir/usr/bin/ytd"
+
+ #app
+ install -d -m755 "$pkgdir/usr/share/ytd"
+ install -m644 msdl_dll.dll rtmpdump_dll.dll ytd.exe ytd.xml ytd-defs.xml "$pkgdir/usr/share/ytd"
+
+ install -d -m755 "$pkgdir/usr/share/ytd/locale"
+ cp -r locale/. "$pkgdir/usr/share/ytd/locale"
+
+ #desktop icon
+ install -Dm644 ytd.desktop "$pkgdir/usr/share/applications/ytd.desktop"
+
+ #docs
+ install -d -m755 "$pkgdir/usr/share/doc/ytd"
+ install -m644 doc/*.txt "$pkgdir/usr/share/doc/ytd"
+
+} \ No newline at end of file
diff --git a/ytd b/ytd
new file mode 100755
index 000000000000..53225731c6ff
--- /dev/null
+++ b/ytd
@@ -0,0 +1,19 @@
+#!/bin/bash
+
+export WINEDEBUG=-all # Supresses Wine debug messages
+
+if [ ! -d "$HOME"/.ytd ] ; then
+ mkdir "$HOME"/.ytd
+ #prepare the environment here
+ cp /usr/share/ytd/ytd.xml "$HOME"/.ytd/ytd.xml || exit 1
+
+ ln -s /usr/share/ytd/ytd-defs.xml "$HOME"/.ytd/ytd-defs.xml || exit 1
+ ln -s /usr/share/ytd/ytd.exe "$HOME"/.ytd/ytd.exe || exit 1
+ ln -s /usr/share/ytd/msdl_dll.dll "$HOME"/.ytd/msdl_dll.dll || exit 1
+ ln -s /usr/share/ytd/rtmpdump_dll.dll "$HOME"/.ytd/rtmpdump_dll.dll || exit 1
+ ln -s -T /usr/share/ytd/locale "$HOME"/.ytd/locale || exit 1
+
+fi
+
+cd "$HOME"/.ytd/
+wine "$HOME"/.ytd/ytd.exe "$@"
diff --git a/ytd.desktop b/ytd.desktop
new file mode 100644
index 000000000000..834b7fe4df0d
--- /dev/null
+++ b/ytd.desktop
@@ -0,0 +1,14 @@
+
+[Desktop Entry]
+Name=ytd
+GenericName=YouTube Downloader
+GenericName[cs]=YouTube Downloader
+Comment=an utility for downloading multimedia content from YouTube and other online streaming services
+Comment[cs]=Nástroj pro stahování videa z YouTube a dalších webových úložišť videa
+Exec=ytd
+StartupNotify=true
+Icon=
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Categories=Network;
diff --git a/ytd.install b/ytd.install
new file mode 100644
index 000000000000..724f3b0741a7
--- /dev/null
+++ b/ytd.install
@@ -0,0 +1,3 @@
+post_upgrade() {
+ post_install $1
+}
diff --git a/ytd.xml b/ytd.xml
new file mode 100644
index 000000000000..7cb142bcabe7
--- /dev/null
+++ b/ytd.xml
@@ -0,0 +1,69 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<ytd>
+ <converters>
+ <activated>0</activated>
+ <converter id="ffmpeg-to-avi">
+ <title>FFmpeg - Změnit kontejner na .AVI</title>
+ <exe_path>ffmpeg.exe</exe_path>
+ <command_line>-i &quot;{$FULLPATH}&quot; -acodec copy -vcodec copy -y &quot;{$FULLPATH}.avi&quot;</command_line>
+ <visibility>minimized</visibility>
+ </converter>
+ <converter id="ffmpeg-convert-to-xvid">
+ <title>FFmpeg - Zkonvertovat film do AVI/XVID</title>
+ <exe_path>ffmpeg.exe</exe_path>
+ <command_line>-i &quot;{$FULLPATH}&quot; -acodec libmp3lame -vcodec mpeg4 -b 1200k -vtag DX50 -y &quot;{$FULLPATH}.avi&quot;</command_line>
+ <visibility>minimized</visibility>
+ </converter>
+ <converter id="ffmpeg-convert-to-h264">
+ <title>FFmpeg - Zkonvertovat film do AVI/H264</title>
+ <exe_path>ffmpeg.exe</exe_path>
+ <command_line>-i &quot;{$FULLPATH}&quot; -vcodec libx264 -preset fast -tune film -profile main -crf 22 -threads 0 -acodec aac -strict experimental -y &quot;{$FULLPATH}.avi&quot;</command_line>
+ <visibility>minimized</visibility>
+ </converter>
+ <converter id="ffmpeg-convert-to-mp3">
+ <title>FFmpeg - Zkonvertovat film do MP3</title>
+ <exe_path>ffmpeg.exe</exe_path>
+ <command_line>-i &quot;{$FULLPATH}&quot; -q:a 0 -vn -y &quot;{$FULLPATH}.mp3&quot;</command_line>
+ <visibility>minimized</visibility>
+ </converter>
+ <converter id="mencoder-to-avi">
+ <title>Mencoder - Změnit kontejner na .AVI</title>
+ <exe_path>mencoder.exe</exe_path>
+ <command_line>-oac copy -ovc copy -of avi -o &quot;{$FULLPATH}.avi&quot; &quot;{$FULLPATH}&quot;</command_line>
+ <visibility>minimized</visibility>
+ </converter>
+ <converter id="mencoder-convert-to-xvid">
+ <title>Mencoder - Zkonvertovat film do AVI/XVID</title>
+ <exe_path>mencoder.exe</exe_path>
+ <command_line>-oac mp3lame -ovc lavc -lavcopts vcodec=mpeg4:vbitrate=1200 -ffourcc xvid -of avi -o &quot;{$FULLPATH}.avi&quot; &quot;{$FULLPATH}&quot;</command_line>
+ <visibility>minimized</visibility>
+ </converter>
+ <converter id="mencoder-convert-to-h264">
+ <title>Mencoder - Zkonvertovat film do AVI/H264</title>
+ <exe_path>mencoder.exe</exe_path>
+ <command_line>-oac mp3lame -ovc x264 -x264encopts bitrate=1200 -of avi -o &quot;{$FULLPATH}.avi&quot; &quot;{$FULLPATH}&quot;</command_line>
+ <visibility>minimized</visibility>
+ </converter>
+ </converters>
+ <config>
+ <portable_mode>1</portable_mode>
+ </config>
+ <gui>
+ <check_for_new_version>0</check_for_new_version>
+ <main_form>
+ <left>0</left>
+ <top>6</top>
+ <width>778</width>
+ <height>300</height>
+ </main_form>
+ <download_list>
+ <column_0_width>160</column_0_width>
+ <column_1_width>80</column_1_width>
+ <column_2_width>96</column_2_width>
+ <column_3_width>200</column_3_width>
+ <column_4_width>64</column_4_width>
+ <column_5_width>120</column_5_width>
+ </download_list>
+ </gui>
+ <download_list/>
+</ytd>