summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkanehekili2022-12-21 21:31:35 +0100
committerkanehekili2022-12-21 21:31:35 +0100
commit09a19fd431d81ddd66e0e9ad223f4bf2004afd60 (patch)
tree89789fb4c21d250109af8c3ca8f3028b93b06f80
parent9fcbc91ab163fbaedd5006fa70cacbc742eb7014 (diff)
downloadaur-09a19fd431d81ddd66e0e9ad223f4bf2004afd60.tar.gz
update PKGBuild, renamed command
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2abac4d12e23..5d0db29a7292 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = ytdownloader
pkgdesc = GKT3 frontend for yt-dlp (the active branch of youtube-dl) with focus on best audio and video. Uses ffmpeg for joining audio & video
- pkgver = 1.4.3
+ pkgver = 1.4.4
pkgrel = 1
url = https://github.com/kanehekili/YoutubeDownloader
- arch = x86_64
+ arch = any
license = GPL2
license = MIT
depends = python
depends = python-gobject
depends = ffmpeg
- source = https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.3/YtDownloader1.4.3.tar
- md5sums = 3a6b8e60bf8c8ee7e8b8af5de5ff75b4
+ source = https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.4/ytdownloader1.4.4.tar
+ md5sums = c2a898a26216dccfdc535bea74c5dc5c
pkgname = ytdownloader
diff --git a/PKGBUILD b/PKGBUILD
index 4ee0c9035a36..0f85d5c91182 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Kanehekili (mat dot wegmann at gmail dot com)
pkgname=ytdownloader
-wsp=YtDownloader
-pkgver=1.4.3
+pkgver=1.4.4
pkgrel=1
pkgdesc="GKT3 frontend for yt-dlp (the active branch of youtube-dl) with focus on best audio and video. Uses ffmpeg for joining audio & video"
url="https://github.com/kanehekili/YoutubeDownloader"
license=('GPL2' 'MIT')
depends=('python' 'python-gobject' 'ffmpeg')
-arch=('x86_64')
-source=(https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.3/YtDownloader1.4.3.tar)
-md5sums=(3a6b8e60bf8c8ee7e8b8af5de5ff75b4)
+arch=('any')
+source=(https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.4/ytdownloader1.4.4.tar)
+md5sums=(c2a898a26216dccfdc535bea74c5dc5c)
package(){
cd ${srcdir}
mkdir -p "${pkgdir}/opt/${pkgname}"
mkdir -p "${pkgdir}/usr/share/applications"
mkdir -p "${pkgdir}/usr/bin"
- rm $srcdir/$wsp/install.sh
- rm $srcdir/$wsp/uninstall.sh
- cp $srcdir/$wsp/YtGui.desktop $pkgdir/usr/share/applications
- cp -r $srcdir/$wsp/* $pkgdir/opt/$pkgname
- cp $srcdir/$wsp/yt-dlp $pkgdir/usr/bin/
+ rm $srcdir/$pkgname/install.sh
+ rm $srcdir/$pkgname/uninstall.sh
+ cp $srcdir/$pkgname/YtGui.desktop $pkgdir/usr/share/applications
+ cp -r $srcdir/$pkgname/* $pkgdir/opt/$pkgname
+ cp $srcdir/$pkgname/yt-dlp $pkgdir/usr/bin/
chmod +x ${pkgdir}/opt/${pkgname}/YtGui.py
chmod a+rx ${pkgdir}/usr/bin/yt-dlp
- ln -s ${pkgdir}/opt/${pkgname}/YtGui.py ${pkgdir}/usr/bin/YtGui
+ ln -sf /opt/${pkgname}/YtGui.py ${pkgdir}/usr/bin/ytgui
}
+