summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkanehekili2021-11-23 00:16:39 +0100
committerkanehekili2021-11-23 00:16:39 +0100
commit3bd68b9547ae7ce4405bbc1a5f1ab350a813ed13 (patch)
treeb383e8691854f019b154bb9b73976cbfba14ccf5
parentcd55d62f4147aec3ea56eab7f4d915d7c8f5f408 (diff)
downloadaur-3bd68b9547ae7ce4405bbc1a5f1ab350a813ed13.tar.gz
Update to yt-dlp backend
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01ad70dc10f9..a176ef4b27e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ytdownloader
- pkgdesc = GKT3 frontend for youtube-dl with focus on best audio and video. Uses ffmpeg for joining audio & video
- pkgver = 1.3.3
- pkgrel = 2
+ pkgdesc = GKT3 frontend for yt-dlp (the active branch of youtube-dl) with focus on best audio and video. Uses ffmpeg for joining audio & video
+ pkgver = 1.4.0
+ pkgrel = 1
url = https://github.com/kanehekili/YoutubeDownloader
arch = x86_64
license = GPL2
@@ -9,8 +9,7 @@ pkgbase = ytdownloader
depends = python
depends = python-gobject
depends = ffmpeg
- depends = youtube-dl
- source = https://github.com/kanehekili/YoutubeDownloader/releases/download/1.3.3/YtDownloader1.3.3.tar
- md5sums = d98c7c16fbb4686adb12ee0a41d319bf
+ source = https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.0/YtDownloader1.4.0.tar
+ md5sums = 4ce7ae6922decc9401506de8f34c86ed
pkgname = ytdownloader
diff --git a/PKGBUILD b/PKGBUILD
index 298cf4d785e1..59d5d7a3ee34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,31 @@
# Maintainer: Kanehekili (mat dot wegmann at gmail dot com)
pkgname=ytdownloader
wsp=YtDownloader
-pkgver=1.3.3
-pkgrel=2
-pkgdesc="GKT3 frontend for youtube-dl with focus on best audio and video. Uses ffmpeg for joining audio & video"
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="GKT3 frontend for yt-dlp (the active branch of youtube-dl) with focus on best audio and video. Uses ffmpeg for joining audio & video"
url="https://github.com/kanehekili/YoutubeDownloader"
license=('GPL2' 'MIT')
-depends=('python' 'python-gobject' 'ffmpeg' 'youtube-dl')
+depends=('python' 'python-gobject' 'ffmpeg')
arch=('x86_64')
-source=(https://github.com/kanehekili/YoutubeDownloader/releases/download/1.3.3/YtDownloader1.3.3.tar)
-md5sums=(d98c7c16fbb4686adb12ee0a41d319bf)
+source=(https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.0/YtDownloader1.4.0.tar)
+md5sums=(4ce7ae6922decc9401506de8f34c86ed)
package(){
cd ${srcdir}
mkdir -p "${pkgdir}/opt/${pkgname}"
mkdir -p "${pkgdir}/usr/share/applications"
mkdir -p "${pkgdir}/usr/bin"
- rm $srcdir/$wsp/install.sh
- rm $srcdir/$wsp/uninstall.sh
- rm $srcdir/$wsp/installYoutube-dl.sh
- cp $srcdir/$wsp/YtGui.desktop $pkgdir/usr/share/applications
+ rm $srcdir/$wsp/install.sh
+ rm $srcdir/$wsp/uninstall.sh
+ rm $srcdir/$wsp/installYoutube-dl.sh
+ cp $srcdir/$wsp/YtGui.desktop $pkgdir/usr/share/applications
cp -r $srcdir/$wsp/* $pkgdir/opt/$pkgname
+ if ! test -f "/usr/local/bin/yt-dlp"; then
+ cp $srcdir/$wsp/yt-dlp $pkgdir/usr/local/bin/
+ fi
chmod +x ${pkgdir}/opt/${pkgname}/YtGui.py
+ chmod a+rx /usr/local/bin/yt-dlp
ln -s ${pkgdir}/opt/${pkgname}/YtGui.py ${pkgdir}/usr/bin/YtGui
}