summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkanehekili2023-10-10 23:40:33 +0200
committerkanehekili2023-10-10 23:40:33 +0200
commit64c2cb3b10fc4bee804796a4cae6d442b1684a2c (patch)
tree3c2b1e1dc4c9f6c60022bb33aad35a97955f8891
parent09a19fd431d81ddd66e0e9ad223f4bf2004afd60 (diff)
downloadaur-64c2cb3b10fc4bee804796a4cae6d442b1684a2c.tar.gz
Adds yt-dlp as dependency
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d0db29a7292..402cce342d2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ytdownloader
pkgdesc = GKT3 frontend for yt-dlp (the active branch of youtube-dl) with focus on best audio and video. Uses ffmpeg for joining audio & video
- pkgver = 1.4.4
+ pkgver = 1.4.5
pkgrel = 1
url = https://github.com/kanehekili/YoutubeDownloader
arch = any
@@ -9,7 +9,8 @@ pkgbase = ytdownloader
depends = python
depends = python-gobject
depends = ffmpeg
- source = https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.4/ytdownloader1.4.4.tar
- md5sums = c2a898a26216dccfdc535bea74c5dc5c
+ depends = yt-dlp
+ source = https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.5/ytdownloader1.4.5.tar
+ md5sums = bd26a157273bbdc42d19f18899736afc
pkgname = ytdownloader
diff --git a/PKGBUILD b/PKGBUILD
index 0f85d5c91182..0b83a94ad0ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Kanehekili (mat dot wegmann at gmail dot com)
pkgname=ytdownloader
-pkgver=1.4.4
+pkgver=1.4.5
pkgrel=1
pkgdesc="GKT3 frontend for yt-dlp (the active branch of youtube-dl) with focus on best audio and video. Uses ffmpeg for joining audio & video"
url="https://github.com/kanehekili/YoutubeDownloader"
license=('GPL2' 'MIT')
-depends=('python' 'python-gobject' 'ffmpeg')
+depends=('python' 'python-gobject' 'ffmpeg' 'yt-dlp')
arch=('any')
-source=(https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.4/ytdownloader1.4.4.tar)
-md5sums=(c2a898a26216dccfdc535bea74c5dc5c)
+source=(https://github.com/kanehekili/YoutubeDownloader/releases/download/1.4.5/ytdownloader1.4.5.tar)
+md5sums=(bd26a157273bbdc42d19f18899736afc)
package(){
cd ${srcdir}
@@ -17,11 +17,11 @@ package(){
mkdir -p "${pkgdir}/usr/bin"
rm $srcdir/$pkgname/install.sh
rm $srcdir/$pkgname/uninstall.sh
+ rm $srcdir/$pkgname/yt-dlp
cp $srcdir/$pkgname/YtGui.desktop $pkgdir/usr/share/applications
cp -r $srcdir/$pkgname/* $pkgdir/opt/$pkgname
- cp $srcdir/$pkgname/yt-dlp $pkgdir/usr/bin/
chmod +x ${pkgdir}/opt/${pkgname}/YtGui.py
- chmod a+rx ${pkgdir}/usr/bin/yt-dlp
+ touch ${pkgdir}/opt/${pkgname}/ytextern
ln -sf /opt/${pkgname}/YtGui.py ${pkgdir}/usr/bin/ytgui
}