summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrkenWhite2021-10-05 19:02:17 +0200
committerOrkenWhite2021-10-05 19:02:17 +0200
commit4849f93835720f074ed41d7997518063f85b4fae (patch)
treef530c93abceda8197f05cac2f00d5435df2ad899
parent1177095f0d6422b347a589cb7cd50fc0294ce443 (diff)
downloadaur-4849f93835720f074ed41d7997518063f85b4fae.tar.gz
Update to 1.8.1
-rw-r--r--PKGBUILD14
-rw-r--r--ytfe.install6
2 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2ddb30a008c..9637edeb47a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
# Maintainer: OrkenWhite <orkenwhite@disroot.org>
pkgname=ytfe
-pkgver=1.7.2
-pkgrel=2
+pkgver=1.8.1
+pkgrel=1
pkgdesc="YouTube frontend"
arch=('x86_64' 'i686')
url="http://oscomp.hu"
license=('custom')
depends=('gtk2')
makedepends=('xz')
-source=('http://oscomp.hu/depot/ytfe.png' 'ytfe.desktop' 'LICENSE')
+source=('http://oscomp.hu/depot/ytfe.png' 'http://oscomp.hu/depot/edl-preloader.lua.xz' 'ytfe.desktop' 'LICENSE')
source_x86_64=('http://oscomp.hu/depot/ytfe_linux_x86_64.xz')
source_i686=('http://oscomp.hu/depot/ytfe_linux_i686.xz')
-sha256sums=( '29220d99cb0e33675e2d349a023eea0877a3befefc61b19f4d901db29f7d1698' '44bc1c569ae7829e65bc5ec3525ad260a2dc64d340da0f9912c4395552134eae' 'bf8e1295602992c618eacbc43a36c201293c8a159f49dd42a724c72f5e8a5267')
-sha256sums_x86_64=('a23d79298bee389742c2a433251db57951413568452198f53c0d9a4edb39826d')
-sha256sums_i686=('2ed9acd0c57a7e713245695311c846d5377fc1fc91e620c87b5aa29c43c0f700')
+sha256sums=( '29220d99cb0e33675e2d349a023eea0877a3befefc61b19f4d901db29f7d1698' '1538efd4ad69915c36a12e48b2fb67606983d8dd38811726640952d6a3c03149' '44bc1c569ae7829e65bc5ec3525ad260a2dc64d340da0f9912c4395552134eae' 'bf8e1295602992c618eacbc43a36c201293c8a159f49dd42a724c72f5e8a5267')
+sha256sums_x86_64=('0c74f857e2a2fabb8b7aeaa71512b1e9e138fee443f6f6bfff120755591b4053')
+sha256sums_i686=('935e71a10f89344760d2e13ad7ecfc5a497930d86057254ef2fd941f89d1b115')
optdepends=('youtube-dl: default downloader'
'mpv: default player'
'vlc: compatible video player')
+install="ytfe.install"
package() {
install -Dm755 ${pkgname}_linux_${arch} $pkgdir/usr/bin/$pkgname
install -Dm644 ${pkgname}.png $pkgdir/usr/share/icons/hicolor/16x16/apps/$pkgname.png
install -Dm644 ${pkgname}.desktop $pkgdir/usr/share/applications/${pkgname}.desktop
install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm755 edl-preloader.lua $pkgdir/usr/bin/edl-preloader
}
diff --git a/ytfe.install b/ytfe.install
new file mode 100644
index 000000000000..87d5fb0c23af
--- /dev/null
+++ b/ytfe.install
@@ -0,0 +1,6 @@
+function post_install(){
+ echo "The EDL preloader script is located under /usr/bin/edl-preloader, if you need it!"
+}
+function post_upgrade(){
+ echo "The EDL preloader script is located under /usr/bin/edl-preloader, if you need it!"
+}