summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrkenWhite2021-08-31 20:10:03 +0200
committerOrkenWhite2021-08-31 20:10:03 +0200
commit831c786e4cc8bd3973e03f18529bf0e4c05853e3 (patch)
treea690f74c4c2a96815a9e9b73c247f42a8d5593b4
parenta21b29fc07e1149c4603f7d645310b4f147803fc (diff)
downloadaur-831c786e4cc8bd3973e03f18529bf0e4c05853e3.tar.gz
Obtained license from developer
-rw-r--r--.SRCINFO4
-rw-r--r--LICENSE1
-rw-r--r--PKGBUILD7
3 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 479179f6a59b..6545574697fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = ytfe
url = http://oscomp.hu
arch = x86_64
arch = i686
- license = unknown
+ license = custom
makedepends = xz
depends = gtk2
optdepends = youtube-dl: default downloader
@@ -13,8 +13,10 @@ pkgbase = ytfe
optdepends = vlc: compatible video player
source = http://oscomp.hu/depot/ytfe.png
source = ytfe.desktop
+ source = LICENSE
sha256sums = 29220d99cb0e33675e2d349a023eea0877a3befefc61b19f4d901db29f7d1698
sha256sums = 44bc1c569ae7829e65bc5ec3525ad260a2dc64d340da0f9912c4395552134eae
+ sha256sums = bf8e1295602992c618eacbc43a36c201293c8a159f49dd42a724c72f5e8a5267
source_x86_64 = http://oscomp.hu/depot/ytfe_linux_x86_64.xz
sha256sums_x86_64 = a23d79298bee389742c2a433251db57951413568452198f53c0d9a4edb39826d
source_i686 = http://oscomp.hu/depot/ytfe_linux_i686.xz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..09f366952909
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1 @@
+Software is freely distributable, but only without modifications and any kind of *direct* fee.
diff --git a/PKGBUILD b/PKGBUILD
index 37fff99d05f0..92e1a631a795 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@ pkgrel=1
pkgdesc="YouTube frontend"
arch=('x86_64' 'i686')
url="http://oscomp.hu"
-license=('unknown')
+license=('custom')
depends=('gtk2')
makedepends=('xz')
-source=('http://oscomp.hu/depot/ytfe.png' 'ytfe.desktop')
+source=('http://oscomp.hu/depot/ytfe.png' 'ytfe.desktop' 'LICENSE')
source_x86_64=('http://oscomp.hu/depot/ytfe_linux_x86_64.xz')
source_i686=('http://oscomp.hu/depot/ytfe_linux_i686.xz')
-sha256sums=( '29220d99cb0e33675e2d349a023eea0877a3befefc61b19f4d901db29f7d1698' '44bc1c569ae7829e65bc5ec3525ad260a2dc64d340da0f9912c4395552134eae')
+sha256sums=( '29220d99cb0e33675e2d349a023eea0877a3befefc61b19f4d901db29f7d1698' '44bc1c569ae7829e65bc5ec3525ad260a2dc64d340da0f9912c4395552134eae' 'bf8e1295602992c618eacbc43a36c201293c8a159f49dd42a724c72f5e8a5267')
sha256sums_x86_64=('a23d79298bee389742c2a433251db57951413568452198f53c0d9a4edb39826d')
sha256sums_i686=('2ed9acd0c57a7e713245695311c846d5377fc1fc91e620c87b5aa29c43c0f700')
optdepends=('youtube-dl: default downloader'
@@ -21,4 +21,5 @@ package() {
install -Dm755 ${pkgname}_linux_${arch} $pkgdir/usr/bin/$pkgname
install -Dm644 ${pkgname}.png $pkgdir/usr/share/icons/hicolor/16x16/apps/$pkgname.png
install -Dm644 ${pkgname}.desktop $pkgdir/usr/share/applications/${pkgname}.desktop
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname}/LICENSE
}