summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-22 08:08:45 +0800
committerzxp198210052024-02-22 08:08:45 +0800
commit09cd64dc75d6e7c7bc1c3c75a2eabf7714439831 (patch)
treedf356a55d9852912e951c37abeb6bdaba653c454
parentb925a5edb4009c104b8dc98cc8efd811d42203dc (diff)
downloadaur-09cd64dc75d6e7c7bc1c3c75a2eabf7714439831.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--ytm-dlp-gui.sh9
3 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30a90314d1dc..787fd5d1e0c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ytm-dlp-gui-bin
pkgdesc = An ElectronJS app for downloading music off Youtube Music.
pkgver = 1.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/RENOMIZER/ytm-dlp-gui
arch = x86_64
license = Unlicense
@@ -13,6 +13,6 @@ pkgbase = ytm-dlp-gui-bin
source = ytm-dlp-gui.sh
sha256sums = 5f13f52d3c3f8d9bbe606da1306ef3fe1046ef621679c4c57099f04b3d9a0cbb
sha256sums = 6b0382b16279f26ff69014300541967a356a666eb0b91b422f6862f6b7dad17e
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = ytm-dlp-gui-bin
diff --git a/PKGBUILD b/PKGBUILD
index 4b44744fab39..8451ebf7dc8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _pkgname=ytm-dlp
pkgname="${_pkgname}-gui-bin"
pkgver=1.2.0
_electronversion=26
-pkgrel=1
+pkgrel=2
pkgdesc="An ElectronJS app for downloading music off Youtube Music."
arch=('x86_64')
url="https://github.com/RENOMIZER/ytm-dlp-gui"
@@ -20,11 +20,11 @@ source=(
)
sha256sums=('5f13f52d3c3f8d9bbe606da1306ef3fe1046ef621679c4c57099f04b3d9a0cbb'
'6b0382b16279f26ff69014300541967a356a666eb0b91b422f6862f6b7dad17e'
- 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|Audio;|AudioVideo;|g" -i "${srcdir}/usr/share/applications/${_pkgname}.desktop"
diff --git a/ytm-dlp-gui.sh b/ytm-dlp-gui.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/ytm-dlp-gui.sh
+++ b/ytm-dlp-gui.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file