summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Golatofski2020-06-03 19:25:11 +0200
committerFelix Golatofski2020-06-03 19:25:11 +0200
commit01efdddcbcd136d244e24ab046b7d14206f37d3a (patch)
tree27696c8353fbe10fb63dd888d05f639e69120ef4
parentc3160b9429f5f95f47e8045da08e0155eaef609d (diff)
downloadaur-01efdddcbcd136d244e24ab046b7d14206f37d3a.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59620049e8c0..337c7a131448 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = ytp-git
pkgdesc = Searches and plays Youtube videos
- pkgver = r49.6c3a081
+ pkgver = r52.b34c5cb
pkgrel = 1
url = https://gitlab.com/uoou/ytp
arch = any
license = GPL2
+ makedepends = git
depends = jq
depends = youtube-dl
depends = mpv
provides = ytp
- source = ytp-git::git+https://gitlab.com/uoou/ytp.git
+ conflicts = ytp
+ source = git+https://gitlab.com/uoou/ytp.git
sha256sums = SKIP
pkgname = ytp-git
diff --git a/PKGBUILD b/PKGBUILD
index 201bad0512a4..07f6beb2b600 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,28 @@
-# Maintainer: Mutantoe <mutantoe+aur@mailbox.org>
+# Maintainer:
+# Contributor: Felix Golatofski <contact@xdfr.de>
+# Contributor: Mutantoe <mutantoe+aur@mailbox.org>
+
+_pkgname=ytp
pkgname=ytp-git
-pkgver=r49.6c3a081
+pkgver=r52.b34c5cb
pkgrel=1
-pkgdesc='Searches and plays Youtube videos'
+pkgdesc="Searches and plays Youtube videos"
arch=('any')
-url='https://gitlab.com/uoou/ytp'
+url="https://gitlab.com/uoou/$_pkgname"
license=('GPL2')
depends=('jq' 'youtube-dl' 'mpv')
-provides=('ytp')
-source=("$pkgname::git+https://gitlab.com/uoou/ytp.git")
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://gitlab.com/uoou/$_pkgname.git")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$srcdir/$_pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$pkgname"
- install -Dm755 ytp "$pkgdir/usr/bin/ytp"
+ cd "$srcdir/$_pkgname"
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
}