summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMutantoe2019-02-07 14:57:25 +0000
committerMutantoe2019-02-07 14:57:25 +0000
commit6cb86c516dd79c6bde7c2a2025cc49056e8d27e5 (patch)
tree963407e462687485697bae2f01aaef84e5819875
downloadaur-6cb86c516dd79c6bde7c2a2025cc49056e8d27e5.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd0f4748d48d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = ytp-git
+ pkgdesc = Searches and plays Youtube videos
+ pkgver = 0.0.0.gb209122
+ pkgrel = 1
+ url = https://gitlab.com/uoou/ytp
+ arch = any
+ license = GPL2
+ depends = jq
+ depends = youtube-dl
+ depends = mpv
+ provides = ytp
+ source = ytp-git::git+https://gitlab.com/uoou/ytp.git
+ sha256sums = SKIP
+
+pkgname = ytp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..80e76ff17566
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mutantoe <mutantoe+aur@mailbox.org>
+pkgname=ytp-git
+pkgver=0.0.0.gb209122
+pkgrel=1
+pkgdesc='Searches and plays Youtube videos'
+arch=('any')
+url='https://gitlab.com/uoou/ytp'
+license=('GPL2')
+depends=('jq' 'youtube-dl' 'mpv')
+provides=('ytp')
+source=("$pkgname::git+https://gitlab.com/uoou/ytp.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ echo 0.0.0.g$(git describe --tags --always | sed 's/^v//;s/-/./g')
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 ytp "$pkgdir/usr/bin/ytp"
+}