summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoragnotek2015-10-20 01:54:18 +0200
committeragnotek2015-10-20 01:54:18 +0200
commit91d1a6167641bb4d25a9ede547f3eba9034729d4 (patch)
treea72b203cffe37f0756527a00b79525f8d3b56e8a
parent99dd7b6c69f1129cc18d757bed2ccdc46ac78cc2 (diff)
downloadaur-91d1a6167641bb4d25a9ede547f3eba9034729d4.tar.gz
updated to Version 7.4
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD6
-rwxr-xr-xYTPLMP428
3 files changed, 31 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6665841b1a8e..9ac37e65d05b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
-# Generated by mksrcinfo v7
-# Sat Sep 26 12:44:38 UTC 2015
+# Generated by makepkg 4.2.1
+# Mon Oct 19 23:51:08 UTC 2015
pkgbase = ytplmp4
pkgdesc = YTPLMP4 - YouTube Playlist to MP3. Download single songs or playlists from Youtube and Soundcloud.
- pkgver = 7.3
- pkgrel = 2
+ pkgver = 7.4
+ pkgrel = 1
url = http://youtube.com/
install = ytplmp4.install
arch = any
@@ -20,10 +20,10 @@ pkgbase = ytplmp4
depends = perl-image-exiftool
depends = lame
options = !strip
- source = https://dl.dropboxusercontent.com/u/9839330/ytplmp4/YTPLMP4-7.3.tar.gz
+ source = https://dl.dropboxusercontent.com/u/9839330/ytplmp4/YTPLMP4-7.4.tar.gz
source = ytplmp4.install
source = ytplmp4.desktop
- md5sums = 7c94947851ec3b392da5ea9218b2f6ec
+ md5sums = 66f745e97bab03b8d3c259dbf67a13f3
md5sums = 9347b695d57d40c8756fcb593f28158c
md5sums = ceae8591b64a369118d4928042cfb403
diff --git a/PKGBUILD b/PKGBUILD
index a0177ea7d5ca..6ae3e8b6ee61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: agnotek <agnostic [dot] sn [at] gmail [dot] com>
pkgname=ytplmp4
-pkgver=7.3
-pkgrel=2
+pkgver=7.4
+pkgrel=1
pkgdesc="YTPLMP4 - YouTube Playlist to MP3. Download single songs or playlists from Youtube and Soundcloud."
arch=('any')
url="http://youtube.com/"
@@ -11,7 +11,7 @@ makedepends=('')
depends=('id3v2' 'python2-eyed3' 'youtube-dl' 'yad' 'curl' 'feh' 'recode' 'smplayer' 'ffmpeg' 'perl-image-exiftool' 'lame')
options=('!strip')
install="ytplmp4.install"
-md5sums=('7c94947851ec3b392da5ea9218b2f6ec'
+md5sums=('66f745e97bab03b8d3c259dbf67a13f3'
'9347b695d57d40c8756fcb593f28158c'
'ceae8591b64a369118d4928042cfb403')
diff --git a/YTPLMP4 b/YTPLMP4
index 69c6d34aaee8..11f020956ca4 100755
--- a/YTPLMP4
+++ b/YTPLMP4
@@ -9,8 +9,8 @@
# https://github.com/flyingrub/scdl GPL v2
# no copyright, just copyleft for my work
#
-
-ytplver=7.3
+set -x
+ytplver=7.4
confver=1
### TODO ChangeLog ###
@@ -41,6 +41,7 @@ rdchnge=false
ytlogin=false
ytmainlnk="https://www.youtube.com/watch?v="
sndcldcnt=0
+SndCloudID="95a4c0ef214f2a4a0852142807b54b35"
sndcldfl=false
declare -a addlnks=()
@@ -64,7 +65,7 @@ chgfile=$HOME/.local/share/YTPLMP3/changelog-ytplmp3.html
if [ -e $confile ]; then
source $confile
[ "$versconf" != "$confver" ] && { rm $confile; logdate=$(echo "`date +%Y-%m-%d`"); versconf=$confver; lastdir=$HOME; lastdat=$(echo "`date +%Y-%m-%d`"); \
- lasturl=""; lastnum="FALSE"; lastid3="TRUE"; preview="TRUE"; rdchnge=false;}
+ lasturl=""; lastnum="FALSE"; lastid3="TRUE"; preview="TRUE"; rdchnge=false; SndCloudID="95a4c0ef214f2a4a0852142807b54b35";}
else
touch $confile
versconf=$confver
@@ -76,6 +77,7 @@ else
lastid3="TRUE"
preview="TRUE"
rdchnge=false
+ SndCloudID="95a4c0ef214f2a4a0852142807b54b35"
fi
# remove old config
[ -e "$HOME/.config/YTPLMP3" ] && { rm -rf $HOME/.config/YTPLMP3/; rm -rf $HOME/.config/YTPLMP3;}
@@ -153,6 +155,13 @@ yad --plug=23 --tabnum=1 --form --separator="," \
--field="use Preview (only works in conjunction with edit ID3-Tag):CHK" \
"$lastdir" "" "!$lasturl" "" "$lastnum" "FALSE" "$lastdat" "1!1..200" "0!0..200" "" "$lastid3" "$preview" &> /tmp/yttb1 2>/dev/null &
+yad --plug=23 --tabnum=4 --form --separator="," \
+ --text="Soundcloud ClientID" \
+ --field="ClientID:CBE" \
+ --field="If Soundcloud download is not working, change the ClientID. Use your own or find one on the internet!\nHere's how-to for obtaining a ClientId\n\nhttps://auth0.com/docs/connections/social/soundcloud:LBL" \
+ "$SndCloudID" &> /tmp/yttb4 2>/dev/null &
+
+
yad --plug=23 --tabnum=3 --form --separator="," \
--text="Change or Add the Genres" \
--field="Use 1 Genre per Line:TXT" \
@@ -164,7 +173,7 @@ yad --plug=23 --tabnum=2 --form --separator="," \
--field="Password:H" \
--field="To download private videos (videos where you have to be signed in) it is crucial that the link to this video is entered in the \"Options\" Tab. Otherwise it will not work\!:LBL" &> /tmp/yttb3 2>/dev/null &
-yad --notebook --key=23 --tab="Options" --tab="Youtube Account" --tab="Edit Genres" --width 405 --height 450 --on-top --title="$ytpltitle" --center \
+yad --notebook --key=23 --tab="Options" --tab="Youtube Account" --tab="Edit Genres" --tab="Soundcloud" --width 405 --height 450 --on-top --title="$ytpltitle" --center \
--separator="," --window-icon="multimedia-player-symbolic" \
--button="Add More:2" \
--button="gtk-cancel:1" \
@@ -180,6 +189,7 @@ case "$?" in
rm -f /tmp/yttb1
rm -f /tmp/yttb2
rm -f /tmp/yttb3
+ rm -f /tmp/yttb4
exit
;;
esac
@@ -215,6 +225,7 @@ rm -f /tmp/yttb1
rm -f /tmp/yttb1
rm -f /tmp/yttb2
rm -f /tmp/yttb3
+ rm -f /tmp/yttb4
exit
fi
fi
@@ -243,6 +254,11 @@ rm -f /tmp/yttb3
if [ -n "$ytaccount" ] && [ -n "$ytpasswrd" ] ; then ytlogin=true; fi
[ $ytlogin = true ] && logininfo="\nusing YouTube-Account: $ytaccount"
+yadsndid=$(cat /tmp/yttb4)
+rm -f /tmp/yttb4
+ SndID=$(echo "$yadsndid" | cut -d, -f1)
+ echo "SndCloudID=$SndID" >> $confile
+
### Counting links
multic=0
[ ${#addlnks[*]} -gt 0 ] && { multic=${#addlnks[*]}; multif=$(echo ${addlnks[@]} | sed 's/ /*/g'); }
@@ -628,8 +644,7 @@ function sndclddl() {
fi
}
#### Soundcloud Integration ####
-clientID="95a4c0ef214f2a4a0852142807b54b35"
-#clientID="b45b1aa10f1ac2941910a7f0d10f8e28"
+clientID=$SndCloudID
curlinstalled=`command -V curl &>/dev/null`
if ! $curlinstalled; then
@@ -929,6 +944,7 @@ unset ytpasswrd
rm -f /tmp/yttb1
rm -f /tmp/yttb2
rm -f /tmp/yttb3
+rm -f /tmp/yttb4
rm -rf $tmppic
rm -rf $tmpjsn
rm -rf $tmpdir