summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBerke Enercan2022-10-19 00:03:37 +0300
committerBerke Enercan2022-10-19 00:03:37 +0300
commit71ca011e41d31dd76ae26c420027dccd5ee86160 (patch)
treedfeef3eddcff2b680205b9fd0d18d066380e13b9
downloadaur-71ca011e41d31dd76ae26c420027dccd5ee86160.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1438738ff1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ytsub
+ pkgdesc = A subscriptions only TUI Youtube client that uses the Invidious API
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/sarowish/ytsub
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ depends = sqlite
+ optdepends = mpv: for playing videos,
+ optdepends = yt-dlp: for playing videos
+ provides = ytsub
+ conflicts = ytsub
+ options = !lto
+ source = ytsub-0.3.1.tar.gz::https://github.com/sarowish/ytsub/archive/refs/tags/v0.3.1.tar.gz
+ sha256sums = 186521d7264c19ee5ec5075aa9ddc5adc12f34b6438869818ffd956c51794bd2
+
+pkgname = ytsub
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0bb79f4e7b4a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Berke Enercan <berkeenercan@tutanota.com>
+
+pkgname=ytsub
+pkgver=0.3.1
+pkgrel=1
+
+pkgdesc='A subscriptions only TUI Youtube client that uses the Invidious API'
+url='https://github.com/sarowish/ytsub'
+arch=('x86_64')
+license=('GPL3')
+depends=('sqlite')
+optdepends=('mpv: for playing videos', 'yt-dlp: for playing videos')
+makedepends=('cargo')
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('186521d7264c19ee5ec5075aa9ddc5adc12f34b6438869818ffd956c51794bd2')
+options=('!lto')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+}