summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Zankich2020-05-12 23:23:24 +0000
committerAdrian Zankich2020-05-12 23:23:24 +0000
commit4c49fd50fd9a902737a0c93c2c80e7fbf9d7b807 (patch)
treebf7197a30ddfca6fb94c9fef4c1fa7346d40a120
downloadaur-4c49fd50fd9a902737a0c93c2c80e7fbf9d7b807.tar.gz
Initial upload: kapp-bin 0.26.0-1
Initial upload: kbld-bin 0.21.0-1 Initial upload: vendir-bin 0.8.0-1 Initial upload: ytt-bin 0.27.1-1 Squash history to include SRCINFO files
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d2712d19130
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = ytt-bin
+ pkgdesc = ytt is a templating tool that understands YAML structure allowing you to focus on your data instead of how to properly escape it
+ pkgver = 0.27.1
+ pkgrel = 1
+ url = https://get-ytt.io/
+ arch = x86_64
+ groups = k14s-bin
+ license = apache
+ source = ytt-linux-amd64-v0.27.1::https://github.com/k14s/ytt/releases/download/v0.27.1/ytt-linux-amd64
+ sha256sums = b53674a21d99576b8d69483113e1ec73d9a3ed7381170a421c9afcf8aa551f15
+
+pkgname = ytt-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c4c080173e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Adrian Zankich <azankich@pivotal.io>
+pkgname=ytt-bin
+pkgdesc="ytt is a templating tool that understands YAML structure allowing you to focus on your data instead of how to properly escape it"
+pkgver=0.27.1
+pkgrel=1
+url="https://get-ytt.io/"
+arch=('x86_64')
+license=('apache')
+groups=('k14s-bin')
+_binary=ytt-linux-amd64
+source=("${_binary}-v${pkgver}::https://github.com/k14s/ytt/releases/download/v${pkgver}/${_binary}")
+sha256sums=("b53674a21d99576b8d69483113e1ec73d9a3ed7381170a421c9afcf8aa551f15")
+
+package() {
+ install -Dm 755 "${srcdir}/${_binary}-v${pkgver}" "${pkgdir}/usr/bin/ytt"
+}