summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-02-22 16:48:05 -0700
committerMark Wagie2024-02-22 16:48:05 -0700
commit935c715bb846fc5a33268606f39b77e17d33ae66 (patch)
tree974d91fdfd34910b52a8a1b143c3d1c6a2dc872a
parentdec52dfde107803d37d279c23f083e599fcb19b9 (diff)
downloadaur-935c715bb846fc5a33268606f39b77e17d33ae66.tar.gz
add ARM64 support
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba39489dcac2..85e1b4b69e24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,6 +4,7 @@ pkgbase = yubico-authenticator
pkgrel = 1
url = https://github.com/Yubico/yubioath-flutter
arch = x86_64
+ arch = aarch64
license = Apache-2.0
makedepends = chrpath
makedepends = clang
diff --git a/PKGBUILD b/PKGBUILD
index a9c979904b6a..1cf875741eb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgdesc="Yubico Authenticator for Desktop"
pkgver=6.4.0
pkgrel=1
_flutter_ver=3.19.0
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/Yubico/yubioath-flutter"
license=('Apache-2.0')
depends=(
@@ -71,15 +71,21 @@ check() {
package() {
cd yubioath-flutter
+ if [ $CARCH == "aarch64" ]; then
+ FLUTTER_ARCH=arm64
+ else
+ FLUTTER_ARCH=x64
+ fi
+
pushd helper
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm755 authenticator-helper.py "$pkgdir/opt/$pkgname/helper/authenticator-helper"
install -Dm755 shell.py -t "$pkgdir/opt/$pkgname/helper/"
popd
- install -Dm755 build/linux/x64/release/bundle/authenticator -t \
+ install -Dm755 build/linux/${FLUTTER_ARCH}/release/bundle/authenticator -t \
"$pkgdir/opt/$pkgname/"
- cp -r build/linux/x64/release/bundle/{data,lib} "$pkgdir/opt/$pkgname"
+ cp -r build/linux/${FLUTTER_ARCH}/release/bundle/{data,lib} "$pkgdir/opt/$pkgname"
install -d "$pkgdir/usr/bin"
ln -s "/opt/$pkgname/authenticator" "$pkgdir/usr/bin/"