summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortuftedocelot2017-03-16 18:17:00 -0500
committertuftedocelot2017-03-16 18:21:42 -0500
commit3911b0f96bee7ff06166672a325cddfbc59fd06b (patch)
treeefd786e6de4de420f788d7a6fd20bf7d41b43dc9
parentb858c5ed446fcfd10fc62b01ea10b016eb28cf67 (diff)
downloadaur-3911b0f96bee7ff06166672a325cddfbc59fd06b.tar.gz
Switch to Python 3 packaging/usage and fix dependencies
Bring the git package in-line with the stock package (never came back to fix up the -git version). Additionally, use the Python 3 based packages instead of Python 2. Thanks @egrupled
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD12
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b13188ebcfbd..071419b1063c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,24 @@
# Generated by mksrcinfo v8
-# Sun Jan 1 17:22:41 UTC 2017
+# Thu Mar 16 23:21:28 UTC 2017
pkgbase = yubico-yubioath-desktop-git
pkgdesc = Crossplatform graphical user interface to generate one-time passwords.
pkgver = 371
- pkgrel = 1
+ pkgrel = 2
url = https://developers.yubico.com/yubioath-desktop/
arch = i686
arch = x86_64
license = GPL
makedepends = git
- makedepends = python2-pyside
- makedepends = python2-pyscard-svn
- makedepends = python2-pbkdf2
- makedepends = python2-setuptools
- makedepends = python2-pyside-tools
- makedepends = python2-crypto
- makedepends = yubikey-personalization
- depends = python2
depends = pcsclite
depends = ccid
+ depends = python-pyside
+ depends = python-pyscard
+ depends = python-pbkdf2
+ depends = python-setuptools
+ depends = python-pyside-tools
+ depends = python-crypto
+ depends = yubikey-personalization
+ depends = python-click
source = git+https://github.com/Yubico/yubioath-desktop.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index aa30805664d5..ab46f57cfbc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_pkgname=yubioath-desktop
pkgname=yubico-${_pkgname}-git
pkgver=371
-pkgrel=1
+pkgrel=2
pkgdesc="Crossplatform graphical user interface to generate one-time passwords."
arch=('i686' 'x86_64')
url="https://developers.yubico.com/yubioath-desktop/"
license=('GPL')
-depends=('python2' 'pcsclite' 'ccid')
-makedepends=('git' 'python2-pyside' 'python2-pyscard-svn' 'python2-pbkdf2' 'python2-setuptools' 'python2-pyside-tools' 'python2-crypto' 'yubikey-personalization')
+depends=('pcsclite' 'ccid' 'python-pyside' 'python-pyscard' 'python-pbkdf2' 'python-setuptools' 'python-pyside-tools' 'python-crypto' 'yubikey-personalization' 'python-click')
+makedepends=('git')
source=("git+https://github.com/Yubico/yubioath-desktop.git")
md5sums=('SKIP')
@@ -22,10 +22,10 @@ package() {
cd "$_pkgname"
git submodule init
git submodule update
- python2 setup.py qt_resources
- python2 setup.py install --root=${pkgdir}
+ python setup.py qt_resources
+ python setup.py install --root=${pkgdir}
- sed -i '/PySide/d' ${pkgdir}/usr/lib/python2.7/site-packages/yubioath_desktop-3.1.1.dev0-py2.7.egg-info/requires.txt
+ sed -i '/PySide/d' ${pkgdir}/usr/lib/python3.6/site-packages/yubioath_desktop-3.1.1.dev0-py3.6.egg-info/requires.txt
mkdir -p ${pkgdir}/usr/share/applications/
install -D -m0644 ${srcdir}/yubioath-desktop/resources/yubioath.desktop ${pkgdir}/usr/share/applications/