summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortuftedocelot2017-04-15 08:18:10 -0500
committertuftedocelot2017-04-15 08:18:10 -0500
commitf9e84bbdb01c21921fa86b6a9c10f26f9dc8c4e5 (patch)
treeeeb280a78b7c30aef8d8057276a1153255b0ef3d
parent3911b0f96bee7ff06166672a325cddfbc59fd06b (diff)
downloadaur-f9e84bbdb01c21921fa86b6a9c10f26f9dc8c4e5.tar.gz
yubioath=desktop: vers bump for new build process
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD28
2 files changed, 23 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 071419b1063c..548c0a4e96ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
# Generated by mksrcinfo v8
-# Thu Mar 16 23:21:28 UTC 2017
+# Sat Apr 15 13:14:50 UTC 2017
pkgbase = yubico-yubioath-desktop-git
pkgdesc = Crossplatform graphical user interface to generate one-time passwords.
- pkgver = 371
- pkgrel = 2
+ pkgver = 636
+ pkgrel = 1
url = https://developers.yubico.com/yubioath-desktop/
arch = i686
arch = x86_64
license = GPL
makedepends = git
+ depends = yubikey-manager
depends = pcsclite
depends = ccid
depends = python-pyside
@@ -19,6 +20,8 @@ pkgbase = yubico-yubioath-desktop-git
depends = python-crypto
depends = yubikey-personalization
depends = python-click
+ depends = qt-solutions-git
+ depends = python-pyotherside
source = git+https://github.com/Yubico/yubioath-desktop.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index ab46f57cfbc7..295a0cd9745a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: tuftedocelot@fastmail.fm
_pkgname=yubioath-desktop
pkgname=yubico-${_pkgname}-git
-pkgver=371
-pkgrel=2
+pkgver=636
+pkgrel=1
pkgdesc="Crossplatform graphical user interface to generate one-time passwords."
arch=('i686' 'x86_64')
url="https://developers.yubico.com/yubioath-desktop/"
license=('GPL')
-depends=('pcsclite' 'ccid' 'python-pyside' 'python-pyscard' 'python-pbkdf2' 'python-setuptools' 'python-pyside-tools' 'python-crypto' 'yubikey-personalization' 'python-click')
+depends=('yubikey-manager' 'pcsclite' 'ccid' 'python-pyside' 'python-pyscard'
+'python-pbkdf2' 'python-setuptools' 'python-pyside-tools' 'python-crypto'
+'yubikey-personalization' 'python-click' 'qt-solutions-git' 'python-pyotherside')
makedepends=('git')
source=("git+https://github.com/Yubico/yubioath-desktop.git")
md5sums=('SKIP')
@@ -17,18 +19,22 @@ pkgver() {
git rev-list --count HEAD
}
-package() {
- mkdir -p ${pkgdir}/usr/bin
- cd "$_pkgname"
+prepare() {
+ cd "${srcdir}/$_pkgname"
git submodule init
git submodule update
- python setup.py qt_resources
- python setup.py install --root=${pkgdir}
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
- sed -i '/PySide/d' ${pkgdir}/usr/lib/python3.6/site-packages/yubioath_desktop-3.1.1.dev0-py3.6.egg-info/requires.txt
+ cd "${srcdir}/$_pkgname"
+ qmake
+ make
+ install -D -m0755 ${srcdir}/$_pkgname/$_pkgname ${pkgdir}/usr/bin/
mkdir -p ${pkgdir}/usr/share/applications/
+ mkdir -p ${pkgdir}/usr/share/icons
install -D -m0644 ${srcdir}/yubioath-desktop/resources/yubioath.desktop ${pkgdir}/usr/share/applications/
- mkdir -p ${pkgdir}/usr/share/pixmaps
- install -D -m0644 ${srcdir}/yubioath-desktop/resources/yubioath.xpm ${pkgdir}/usr/share/pixmaps
+ install -D -m0644 ${srcdir}/yubioath-desktop/resources/icons/yubioath.png ${pkgdir}/usr/share/icons/
}