summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortherojam2019-02-20 20:20:04 +0100
committertherojam2019-02-20 20:20:04 +0100
commitff9542b69c2a248d5b935a9cf520eff5307faa14 (patch)
tree131e8013b2c29c3095e17f4e456097d43e9ac071
parentbfcb289c21f510f171bb11af9ee7c54f202944d0 (diff)
downloadaur-ff9542b69c2a248d5b935a9cf520eff5307faa14.tar.gz
change license and package routines
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f103b6ccf76..6e339b916c4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,7 +4,7 @@ pkgbase = yubikey-full-disk-encryption-git
pkgrel = 1
url = https://github.com/agherzan/yubikey-full-disk-encryption
arch = any
- license = GPL
+ license = Apache
makedepends = git
depends = yubikey-personalization
depends = cryptsetup
diff --git a/PKGBUILD b/PKGBUILD
index 527ab834db67..1d986a38750f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgrel=1
pkgdesc='Use YubiKey to unlock a LUKS partition'
arch=('any')
url='https://github.com/agherzan/yubikey-full-disk-encryption'
-license=('GPL')
+license=('Apache')
depends=('yubikey-personalization' 'cryptsetup' 'udisks2' 'expect')
makedepends=('git')
backup=('etc/ykfde.conf')
@@ -15,11 +15,11 @@ source=('git+https://github.com/agherzan/yubikey-full-disk-encryption.git')
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- }
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- cd "${pkgname}"
- make DESTDIR="${pkgdir}" install
- }
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
+}