summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-11-24 01:44:07 -0500
committerJean Lucas2019-11-24 04:13:51 -0500
commitfbf8445690f7e25c120bee050e35a965e0d25fbd (patch)
tree2348a214ce482a58b2325dbd0ec10ca251e998f8
parenta4920d6b6f055ed8dd23b55afb338a68b8f05c05 (diff)
downloadaur-fbf8445690f7e25c120bee050e35a965e0d25fbd.tar.gz
1.4.7
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD27
-rw-r--r--electron-builder.patch20
-rw-r--r--yuna.desktop1
4 files changed, 30 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8bfe08d8cab..1823e7eae7e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,47 +1,25 @@
pkgbase = yuna
pkgdesc = Anime player integating AniList, Crunchyroll, and Hidive
- pkgver = 1.3.9
+ pkgver = 1.4.7
pkgrel = 1
url = https://yuna.moe
arch = i686
arch = x86_64
license = AGPL3
makedepends = yarn
- makedepends = nodejs>=10
+ makedepends = nodejs
+ makedepends = node-gyp
makedepends = python2
- depends = alsa-lib
- depends = atk
- depends = at-spi2-atk
- depends = at-spi2-core
- depends = cairo
- depends = dbus
- depends = gdk-pixbuf2
- depends = glib2
depends = gtk3
- depends = hicolor-icon-theme
- depends = libcups
- depends = libx11
- depends = libxcb
- depends = libxcomposite
- depends = libxcursor
- depends = libxdamage
- depends = libxext
- depends = libxfixes
- depends = libxi
- depends = libxrandr
- depends = libxrender
depends = libxss
- depends = libxtst
- depends = nspr
depends = nss
- depends = pango
options = !strip
- source = yuna-1.3.9.tar.gz::https://github.com/BeeeQueue/yuna/archive/v1.3.9.tar.gz
+ source = yuna-1.4.7.tar.gz::https://github.com/BeeeQueue/yuna/archive/v1.4.7.tar.gz
source = electron-builder.patch
source = yuna.desktop
- sha512sums = 519f3ec59b265a757b17617e26d55a36486cbf63785386c894b5afc055ca958c96d8fbe1c08d5d3b69cfeb76dc4b7a6dd798db4c946b1b9991e1febb9d3e5470
- sha512sums = e6b50f112b1123e0308edb0fd28a7ebaf56af006b6c20fc6fbc078f95fdf85b9f5e5f024951b7a10599cdaeaee6f47ead9647c3698615216e774976100c354e7
- sha512sums = 8cff81afac9ed702d14bfdf28cc8f5db83895360ab7b68c94aa59e260cf3a0c94597a6a083f86cd00a9b85be751a263879eca7ed25d8a91a8a0cc6c3f36a393a
+ sha512sums = bb1ca7cf4b20dc7b2dfbfe17f5d2bf895a4cc49cda7283a97be4568ae4d740e65ec64e9a00a0c01018222148b931e40ec2ccd984024938327450a451cedf25ce
+ sha512sums = 893065948029906084e5a7f94982a666fc553b294d2a423dc1642d6c67b1755e1f6ac0304adf726ff26c6b1ce74fbb8fc76a8bd129527abb3d7529ca59ebf643
+ sha512sums = 1853e9eac6b6a3b0734711d0803135902f118168603c795543de3296928293773d2be7a2aef05b045b737305d6cb50273e01843544de53d9caf06d0b4dc3e982
pkgname = yuna
diff --git a/PKGBUILD b/PKGBUILD
index 30c1646cadc8..1d65327b2bbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,50 @@
# Maintainer: Jean Lucas <jean@4ray.co>
pkgname=yuna
-pkgver=1.3.9
+pkgver=1.4.7
pkgrel=1
pkgdesc='Anime player integating AniList, Crunchyroll, and Hidive'
arch=(i686 x86_64)
url=https://yuna.moe
license=(AGPL3)
-depends=(alsa-lib atk at-spi2-atk at-spi2-core cairo dbus gdk-pixbuf2 glib2 gtk3 hicolor-icon-theme libcups libx11 libxcb libxcomposite libxcursor libxdamage libxext libxfixes libxi libxrandr libxrender libxss libxtst nspr nss pango)
-makedepends=(yarn 'nodejs>=10' python2)
+depends=(gtk3 libxss nss)
+makedepends=(yarn nodejs node-gyp python2)
options=(!strip)
source=($pkgname-$pkgver.tar.gz::https://github.com/BeeeQueue/yuna/archive/v$pkgver.tar.gz
electron-builder.patch
yuna.desktop)
-sha512sums=('519f3ec59b265a757b17617e26d55a36486cbf63785386c894b5afc055ca958c96d8fbe1c08d5d3b69cfeb76dc4b7a6dd798db4c946b1b9991e1febb9d3e5470'
- 'e6b50f112b1123e0308edb0fd28a7ebaf56af006b6c20fc6fbc078f95fdf85b9f5e5f024951b7a10599cdaeaee6f47ead9647c3698615216e774976100c354e7'
- '8cff81afac9ed702d14bfdf28cc8f5db83895360ab7b68c94aa59e260cf3a0c94597a6a083f86cd00a9b85be751a263879eca7ed25d8a91a8a0cc6c3f36a393a')
+sha512sums=('bb1ca7cf4b20dc7b2dfbfe17f5d2bf895a4cc49cda7283a97be4568ae4d740e65ec64e9a00a0c01018222148b931e40ec2ccd984024938327450a451cedf25ce'
+ '893065948029906084e5a7f94982a666fc553b294d2a423dc1642d6c67b1755e1f6ac0304adf726ff26c6b1ce74fbb8fc76a8bd129527abb3d7529ca59ebf643'
+ '1853e9eac6b6a3b0734711d0803135902f118168603c795543de3296928293773d2be7a2aef05b045b737305d6cb50273e01843544de53d9caf06d0b4dc3e982')
prepare() {
cd $pkgname-$pkgver
+
# Tell Electron Builder to only target a directory build
- patch -Np1 < ../electron-builder.patch
+ patch -Np0 < ../electron-builder.patch
+
+ # Remove GIT_TAG const since this is an archive download
+ # Remove Sentry source maps config since we don't have project info
+ sed -r '6,10d;62,80d' -i vue.config.js
}
build() {
cd $pkgname-$pkgver
yarn
+ yarn get-schema
yarn build
}
package() {
- install -Dm 644 yuna.desktop -t "$pkgdir"/usr/share/applications
-
cd yuna-$pkgver
- mkdir "$pkgdir"/usr/{lib,bin}
+ install -d "$pkgdir"/usr/{lib,bin}
cp -a dist_electron/linux-unpacked "$pkgdir"/usr/lib/yuna
ln -s /usr/lib/yuna/yuna "$pkgdir"/usr/bin
+ install -Dm 644 ../yuna.desktop -t "$pkgdir"/usr/share/applications
for i in 64 128 256 512; do
install -Dm 644 public/icons/${i}x${i}.png \
"$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/yuna.png
done
-
- install -Dm 644 LICENSE.md -t "$pkgdir"/usr/share/licenses/yuna
}
diff --git a/electron-builder.patch b/electron-builder.patch
index 11dbe696982a..71a588ceaf56 100644
--- a/electron-builder.patch
+++ b/electron-builder.patch
@@ -1,18 +1,14 @@
---- a/vue.config.js
-+++ b/vue.config.js
-@@ -2,6 +2,15 @@
- * @type { ProjectOptions }
- */
- module.exports = {
-+ pluginOptions: {
-+ electronBuilder: {
+--- vue.config.js
++++ vue.config.js
+@@ -84,6 +84,11 @@
+ chainWebpackMainProcess: config => {
+ config.resolve.alias.set('@', resolve(__dirname, 'src'))
+ },
+ builderOptions: {
+ linux: {
+ target: 'dir'
+ }
+ }
-+ }
-+ },
- css: {
- sourceMap: true,
+ },
},
+ }
diff --git a/yuna.desktop b/yuna.desktop
index 67d9c54872dc..9edcc9d3c938 100644
--- a/yuna.desktop
+++ b/yuna.desktop
@@ -1,5 +1,4 @@
[Desktop Entry]
-Version=1.0
Type=Application
Name=Yuna
Comment=Anime player integating AniList, Crunchyroll, and Hidive