summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraypawn2016-05-16 18:03:45 +0900
committergraypawn2016-05-16 18:03:45 +0900
commitcedad66c46d2eaa0310a7acd8ef233cb93188da9 (patch)
treeda4d493af32df2b5b1e04b70b10dd8553826473f
downloadaur-cedad66c46d2eaa0310a7acd8ef233cb93188da9.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD22
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd1a856bc7a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = yusuke
+ pkgdesc = pacman update notifier
+ pkgver = 1.7.6
+ pkgrel = 1
+ url = https://github.com/graypawn/yusuke
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = pacman
+ depends = libnotify
+ depends = bash
+ conflicts = yusuke
+ source = https://github.com/graypawn/yusuke/archive/v1.7.6.zip
+ md5sums = c642ace6ecc0c28a8be62d899a9cf48a
+
+pkgname = yusuke
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2636ed36f771
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*~
+#*
+.#*
+/*.zip
+/*.pkg.tar.xz
+/src/
+/pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cac96af24213
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: graypawn <choi.pawn @gmail.com>
+pkgname=yusuke
+_gitname=yusuke
+pkgver=1.7.6
+pkgrel=1
+pkgdesc="pacman update notifier"
+
+arch=('i686' 'x86_64')
+url="https://github.com/graypawn/yusuke"
+license=('GPL3')
+
+conflicts=('yusuke')
+depends=('pacman' 'libnotify' 'bash')
+source=("https://github.com/graypawn/yusuke/archive/v$pkgver.zip")
+md5sums=('c642ace6ecc0c28a8be62d899a9cf48a')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 yusuke "$pkgdir/usr/bin/yusuke"
+ install -Dm644 yusuke@.service "$pkgdir/etc/systemd/system/yusuke@.service"
+ install -Dm644 yusuke@.timer "$pkgdir/etc/systemd/system/yusuke@.timer"
+}