summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Valdes2020-01-20 23:15:46 -0500
committerAlejandro Valdes2020-01-20 23:15:46 -0500
commit39aac2f45829e231e62531fd2bb64c96d6c9175e (patch)
tree68422308797abb8364cd13ad3be976cdbc9387be
parente8c77404a306ec199f75b55888fdfcf10049a120 (diff)
downloadaur-39aac2f45829e231e62531fd2bb64c96d6c9175e.tar.gz
Bump to 2.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD7
-rw-r--r--archlinux.patch36
3 files changed, 33 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37af965a227d..9e972e4ab72d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = yuview
pkgdesc = The Free and Open Source Cross Platform YUV Viewer with an advanced analytics toolset
- pkgver = 2.3
+ pkgver = 2.4
pkgrel = 1
url = https://github.com/IENT/YUView
install = yuview.install
arch = x86_64
- license = GPL
+ license = GPL3
depends = qt5-base
depends = desktop-file-utils
depends = libde265
provides = yuview
conflicts = yuview
conflicts = YUView
- source = https://github.com/IENT/YUView/archive/2.3.zip
+ source = https://github.com/IENT/YUView/archive/2.4.zip
source = archlinux.patch
- md5sums = c457c7fa6b122752a1e6d1aaf25352c4
- md5sums = 14f0ec2312e20609b2576fde0885e730
+ md5sums = 08b016f87bc060081201ae33d0df9d60
+ md5sums = 5c9667460bf100f2c770b35c2de9cf64
pkgname = yuview
diff --git a/PKGBUILD b/PKGBUILD
index f57cf69d302d..98e50cd8ba50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alejandro Valdes <alejandrovaldes at live dot com>
pkgname=yuview
_pkgname=YUView
-pkgver=2.3
+pkgver=2.4
pkgrel=1
pkgdesc="The Free and Open Source Cross Platform YUV Viewer with an advanced analytics toolset"
arch=('x86_64')
@@ -13,8 +13,8 @@ conflicts=("$pkgname" "$_pkgname")
source=("${url}/archive/${pkgver}.zip"
'archlinux.patch')
noextract=()
-md5sums=('c457c7fa6b122752a1e6d1aaf25352c4'
- '14f0ec2312e20609b2576fde0885e730')
+md5sums=('08b016f87bc060081201ae33d0df9d60'
+ '5c9667460bf100f2c770b35c2de9cf64')
install="$pkgname.install"
prepare() {
@@ -38,4 +38,5 @@ check() {
package() {
cd build
make INSTALL_ROOT="$pkgdir" install
+ rm -r "$pkgdir/usr/tests"
}
diff --git a/archlinux.patch b/archlinux.patch
index 4659bb0c644c..8042bd4e2805 100644
--- a/archlinux.patch
+++ b/archlinux.patch
@@ -1,13 +1,25 @@
-diff --git a/YUView.pro b/YUView.pro
-index b92db488..23615f79 100644
---- a/YUView.pro
-+++ b/YUView.pro
-@@ -177,7 +177,7 @@ OTHER_FILES += \
-
+diff --git a/YUViewApp/YUViewApp.pro b/YUViewApp/YUViewApp.pro
+index 2f1d5742..853e68d3 100644
+--- a/YUViewApp/YUViewApp.pro
++++ b/YUViewApp/YUViewApp.pro
+@@ -13,7 +13,7 @@ LIBS += -L$$top_builddir/YUViewLib -lYUViewLib
+
unix:!mac {
- isEmpty(PREFIX) {
-- PREFIX = /usr/local
-+ PREFIX = /usr
- }
- isEmpty(BINDIR) {
- BINDIR = bin
+ isEmpty(PREFIX) {
+- PREFIX = /usr/local
++ PREFIX = /usr
+ }
+ isEmpty(BINDIR) {
+ BINDIR = bin
+diff --git a/YUViewLib/src/filesource/fileSource.h b/YUViewLib/src/filesource/fileSource.h
+index 4177c3d7..3cb7af70 100644
+--- a/YUViewLib/src/filesource/fileSource.h
++++ b/YUViewLib/src/filesource/fileSource.h
+@@ -38,6 +38,7 @@
+ #include <QFileSystemWatcher>
+ #include <QMutex>
+ #include <QMutexLocker>
++#include <QSize>
+ #include <QString>
+
+ #include "common/fileInfo.h"