summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Valdes2021-07-09 13:19:48 -0500
committerAlejandro Valdes2021-07-09 13:19:48 -0500
commit43e2b8c0cb4ddaa0ff910efb3a38f5a682f10798 (patch)
tree300a9346d3e4658a56d9029d4af8780c7e9aa474
parentfb06e833fbefda508e141c36c50e6b2ba6a9826e (diff)
downloadaur-43e2b8c0cb4ddaa0ff910efb3a38f5a682f10798.tar.gz
Bump to 2.11.1
-rw-r--r--PKGBUILD6
-rw-r--r--archlinux.patch24
2 files changed, 3 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cabdb6a320d0..be95de007163 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alejandro Valdes <alejandrovaldes at live dot com>
pkgname=yuview
_pkgname=YUView
-pkgver=2.7
+pkgver=2.11.1
pkgrel=1
pkgdesc="The Free and Open Source Cross Platform YUV Viewer with an advanced analytics toolset"
arch=('x86_64')
@@ -13,11 +13,11 @@ depends=('qt5-base'
'libde265')
provides=("$pkgname")
conflicts=("$pkgname" "$_pkgname")
-source=("git+${url}.git#commit=24c65edbc2e73125103e54db9d11e0391e48d27b"
+source=("git+${url}.git#commit=4ae46b79575a54d3139c1ae0dbf03947344fe081"
'archlinux.patch')
noextract=()
md5sums=('SKIP'
- '095b1623302cec0ab619dd506751f1fc')
+ 'b6ac6b6b839023b3b72fc0ff2fc2098f')
install="$pkgname.install"
prepare() {
diff --git a/archlinux.patch b/archlinux.patch
index 36e1feb84825..d3fbfd027082 100644
--- a/archlinux.patch
+++ b/archlinux.patch
@@ -28,27 +28,3 @@ index cf267b8f..05d41fb3 100644
#define MAX_RECENT_FILES 10
-diff --git a/YUViewLib/src/statistics/statisticHandler.cpp b/YUViewLib/src/statistics/statisticHandler.cpp
-index a62efa42..1e9d5915 100644
---- a/YUViewLib/src/statistics/statisticHandler.cpp
-+++ b/YUViewLib/src/statistics/statisticHandler.cpp
-@@ -35,6 +35,7 @@
- #include <cmath>
- #include <QPainter>
- #include <QtMath>
-+#include <QPainterPath>
-
- #include "common/functions.h"
-
-diff --git a/YUViewLib/src/ui/views/splitViewWidget.cpp b/YUViewLib/src/ui/views/splitViewWidget.cpp
-index ff5723ba..4a29d723 100644
---- a/YUViewLib/src/ui/views/splitViewWidget.cpp
-+++ b/YUViewLib/src/ui/views/splitViewWidget.cpp
-@@ -38,6 +38,7 @@
- #include <QInputDialog>
- #include <QMessageBox>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QSettings>
- #include <QTextDocument>
-