summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Valdes2020-04-05 17:23:17 -0500
committerAlejandro Valdes2020-04-05 17:23:17 -0500
commitb5a9150e22a0a767ddbe9e21db3d9071924ee5d1 (patch)
tree0733022e44ad2c0c897808ad02f525194ded2a90
parent7eae3047464df928113a75c7036f5d3d76c2517c (diff)
downloadaur-b5a9150e22a0a767ddbe9e21db3d9071924ee5d1.tar.gz
Bump to 2.6
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rw-r--r--archlinux.patch35
3 files changed, 33 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24fab54404be..d479015ff122 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = yuview
pkgdesc = The Free and Open Source Cross Platform YUV Viewer with an advanced analytics toolset
- pkgver = 2.4
- pkgrel = 2
+ pkgver = 2.6
+ pkgrel = 1
url = https://github.com/IENT/YUView
install = yuview.install
arch = x86_64
@@ -13,10 +13,10 @@ pkgbase = yuview
provides = yuview
conflicts = yuview
conflicts = YUView
- source = https://github.com/IENT/YUView/archive/2.4.zip
+ source = git+https://github.com/IENT/YUView.git#commit=5e845470cf0571e5fabc6c0c2c5db4c6f3cec5af
source = archlinux.patch
- md5sums = 08b016f87bc060081201ae33d0df9d60
- md5sums = 5c9667460bf100f2c770b35c2de9cf64
+ md5sums = SKIP
+ md5sums = a2d1cca1fade739a2fc8b918ff6536f3
pkgname = yuview
diff --git a/PKGBUILD b/PKGBUILD
index 84c305c972b6..189be50b30cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Alejandro Valdes <alejandrovaldes at live dot com>
pkgname=yuview
_pkgname=YUView
-pkgver=2.4
-pkgrel=2
+pkgver=2.6
+pkgrel=1
pkgdesc="The Free and Open Source Cross Platform YUV Viewer with an advanced analytics toolset"
arch=('x86_64')
-url="https://github.com/IENT/YUView"
+url="https://github.com/IENT/${_pkgname}"
license=('GPL3')
depends=('qt5-base'
'qt5-charts'
@@ -13,19 +13,19 @@ depends=('qt5-base'
'libde265')
provides=("$pkgname")
conflicts=("$pkgname" "$_pkgname")
-source=("${url}/archive/${pkgver}.zip"
+source=("git+${url}.git#commit=5e845470cf0571e5fabc6c0c2c5db4c6f3cec5af"
'archlinux.patch')
noextract=()
-md5sums=('08b016f87bc060081201ae33d0df9d60'
- '5c9667460bf100f2c770b35c2de9cf64')
+md5sums=('SKIP'
+ 'a2d1cca1fade739a2fc8b918ff6536f3')
install="$pkgname.install"
prepare() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "$srcdir/$_pkgname"
patch --forward --strip=1 --input="${srcdir}/archlinux.patch"
mkdir -p "$srcdir/build"
cd "$srcdir/build"
- qmake -o Makefile ../$_pkgname-$pkgver/$_pkgname.pro -spec linux-g++
+ qmake -o Makefile ../$_pkgname/$_pkgname.pro -spec linux-g++
}
build() {
@@ -41,5 +41,4 @@ check() {
package() {
cd build
make INSTALL_ROOT="$pkgdir" install
- rm -r "$pkgdir/usr/tests"
}
diff --git a/archlinux.patch b/archlinux.patch
index 8042bd4e2805..23e189509c38 100644
--- a/archlinux.patch
+++ b/archlinux.patch
@@ -1,9 +1,9 @@
diff --git a/YUViewApp/YUViewApp.pro b/YUViewApp/YUViewApp.pro
-index 2f1d5742..853e68d3 100644
+index bcc97c2b..a8829201 100644
--- a/YUViewApp/YUViewApp.pro
+++ b/YUViewApp/YUViewApp.pro
-@@ -13,7 +13,7 @@ LIBS += -L$$top_builddir/YUViewLib -lYUViewLib
-
+@@ -19,7 +19,7 @@ win32 {
+
unix:!mac {
isEmpty(PREFIX) {
- PREFIX = /usr/local
@@ -11,15 +11,20 @@ index 2f1d5742..853e68d3 100644
}
isEmpty(BINDIR) {
BINDIR = bin
-diff --git a/YUViewLib/src/filesource/fileSource.h b/YUViewLib/src/filesource/fileSource.h
-index 4177c3d7..3cb7af70 100644
---- a/YUViewLib/src/filesource/fileSource.h
-+++ b/YUViewLib/src/filesource/fileSource.h
-@@ -38,6 +38,7 @@
- #include <QFileSystemWatcher>
- #include <QMutex>
- #include <QMutexLocker>
-+#include <QSize>
- #include <QString>
-
- #include "common/fileInfo.h"
+diff --git a/YUViewLib/src/common/typedef.h b/YUViewLib/src/common/typedef.h
+index 13ade597..fd77de62 100644
+--- a/YUViewLib/src/common/typedef.h
++++ b/YUViewLib/src/common/typedef.h
+@@ -213,12 +213,7 @@ private:
+ #define YUVIEW_VERSION "Unknown"
+ #endif
+
+-#ifndef YUVIEW_HASH
+ #define VERSION_CHECK 0
+-#define YUVIEW_HASH 0
+-#else
+-#define VERSION_CHECK 1
+-#endif
+
+ #define MAX_RECENT_FILES 10
+