summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Valdes2019-12-23 16:51:42 -0500
committerAlejandro Valdes2019-12-23 16:51:42 -0500
commite8c77404a306ec199f75b55888fdfcf10049a120 (patch)
treef3bee75c1f3f94da85bf88c7c952ddef1e1a226b
downloadaur-e8c77404a306ec199f75b55888fdfcf10049a120.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
-rw-r--r--archlinux.patch13
-rw-r--r--yuview.install11
4 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37af965a227d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = yuview
+ pkgdesc = The Free and Open Source Cross Platform YUV Viewer with an advanced analytics toolset
+ pkgver = 2.3
+ pkgrel = 1
+ url = https://github.com/IENT/YUView
+ install = yuview.install
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ depends = desktop-file-utils
+ depends = libde265
+ provides = yuview
+ conflicts = yuview
+ conflicts = YUView
+ source = https://github.com/IENT/YUView/archive/2.3.zip
+ source = archlinux.patch
+ md5sums = c457c7fa6b122752a1e6d1aaf25352c4
+ md5sums = 14f0ec2312e20609b2576fde0885e730
+
+pkgname = yuview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f57cf69d302d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Alejandro Valdes <alejandrovaldes at live dot com>
+pkgname=yuview
+_pkgname=YUView
+pkgver=2.3
+pkgrel=1
+pkgdesc="The Free and Open Source Cross Platform YUV Viewer with an advanced analytics toolset"
+arch=('x86_64')
+url="https://github.com/IENT/YUView"
+license=('GPL3')
+depends=('qt5-base' 'desktop-file-utils' 'libde265')
+provides=("$pkgname")
+conflicts=("$pkgname" "$_pkgname")
+source=("${url}/archive/${pkgver}.zip"
+ 'archlinux.patch')
+noextract=()
+md5sums=('c457c7fa6b122752a1e6d1aaf25352c4'
+ '14f0ec2312e20609b2576fde0885e730')
+install="$pkgname.install"
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/archlinux.patch"
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+ qmake -o Makefile ../$_pkgname-$pkgver/$_pkgname.pro -spec linux-g++
+}
+
+build() {
+ cd build
+ make
+}
+
+check() {
+ cd build
+ make -k check
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+}
diff --git a/archlinux.patch b/archlinux.patch
new file mode 100644
index 000000000000..4659bb0c644c
--- /dev/null
+++ b/archlinux.patch
@@ -0,0 +1,13 @@
+diff --git a/YUView.pro b/YUView.pro
+index b92db488..23615f79 100644
+--- a/YUView.pro
++++ b/YUView.pro
+@@ -177,7 +177,7 @@ OTHER_FILES += \
+
+ unix:!mac {
+ isEmpty(PREFIX) {
+- PREFIX = /usr/local
++ PREFIX = /usr
+ }
+ isEmpty(BINDIR) {
+ BINDIR = bin
diff --git a/yuview.install b/yuview.install
new file mode 100644
index 000000000000..25fdc2b1a8cc
--- /dev/null
+++ b/yuview.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}