summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Valdes2020-07-10 20:56:56 -0500
committerAlejandro Valdes2020-07-10 20:56:56 -0500
commitfb06e833fbefda508e141c36c50e6b2ba6a9826e (patch)
tree4fef856f0c92d4cfe8b4241695a6fadb51f20ac8
parentb5a9150e22a0a767ddbe9e21db3d9071924ee5d1 (diff)
downloadaur-fb06e833fbefda508e141c36c50e6b2ba6a9826e.tar.gz
Bump to 2.7
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--archlinux.patch30
3 files changed, 33 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d479015ff122..af8d6fbbc782 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuview
pkgdesc = The Free and Open Source Cross Platform YUV Viewer with an advanced analytics toolset
- pkgver = 2.6
+ pkgver = 2.7
pkgrel = 1
url = https://github.com/IENT/YUView
install = yuview.install
@@ -13,10 +13,10 @@ pkgbase = yuview
provides = yuview
conflicts = yuview
conflicts = YUView
- source = git+https://github.com/IENT/YUView.git#commit=5e845470cf0571e5fabc6c0c2c5db4c6f3cec5af
+ source = git+https://github.com/IENT/YUView.git#commit=24c65edbc2e73125103e54db9d11e0391e48d27b
source = archlinux.patch
md5sums = SKIP
- md5sums = a2d1cca1fade739a2fc8b918ff6536f3
+ md5sums = 095b1623302cec0ab619dd506751f1fc
pkgname = yuview
diff --git a/PKGBUILD b/PKGBUILD
index 189be50b30cc..cabdb6a320d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alejandro Valdes <alejandrovaldes at live dot com>
pkgname=yuview
_pkgname=YUView
-pkgver=2.6
+pkgver=2.7
pkgrel=1
pkgdesc="The Free and Open Source Cross Platform YUV Viewer with an advanced analytics toolset"
arch=('x86_64')
@@ -13,11 +13,11 @@ depends=('qt5-base'
'libde265')
provides=("$pkgname")
conflicts=("$pkgname" "$_pkgname")
-source=("git+${url}.git#commit=5e845470cf0571e5fabc6c0c2c5db4c6f3cec5af"
+source=("git+${url}.git#commit=24c65edbc2e73125103e54db9d11e0391e48d27b"
'archlinux.patch')
noextract=()
md5sums=('SKIP'
- 'a2d1cca1fade739a2fc8b918ff6536f3')
+ '095b1623302cec0ab619dd506751f1fc')
install="$pkgname.install"
prepare() {
diff --git a/archlinux.patch b/archlinux.patch
index 23e189509c38..36e1feb84825 100644
--- a/archlinux.patch
+++ b/archlinux.patch
@@ -1,5 +1,5 @@
diff --git a/YUViewApp/YUViewApp.pro b/YUViewApp/YUViewApp.pro
-index bcc97c2b..a8829201 100644
+index 4e5c0d34..09afecd2 100644
--- a/YUViewApp/YUViewApp.pro
+++ b/YUViewApp/YUViewApp.pro
@@ -19,7 +19,7 @@ win32 {
@@ -12,10 +12,10 @@ index bcc97c2b..a8829201 100644
isEmpty(BINDIR) {
BINDIR = bin
diff --git a/YUViewLib/src/common/typedef.h b/YUViewLib/src/common/typedef.h
-index 13ade597..fd77de62 100644
+index cf267b8f..05d41fb3 100644
--- a/YUViewLib/src/common/typedef.h
+++ b/YUViewLib/src/common/typedef.h
-@@ -213,12 +213,7 @@ private:
+@@ -212,12 +212,7 @@ private:
#define YUVIEW_VERSION "Unknown"
#endif
@@ -28,3 +28,27 @@ index 13ade597..fd77de62 100644
#define MAX_RECENT_FILES 10
+diff --git a/YUViewLib/src/statistics/statisticHandler.cpp b/YUViewLib/src/statistics/statisticHandler.cpp
+index a62efa42..1e9d5915 100644
+--- a/YUViewLib/src/statistics/statisticHandler.cpp
++++ b/YUViewLib/src/statistics/statisticHandler.cpp
+@@ -35,6 +35,7 @@
+ #include <cmath>
+ #include <QPainter>
+ #include <QtMath>
++#include <QPainterPath>
+
+ #include "common/functions.h"
+
+diff --git a/YUViewLib/src/ui/views/splitViewWidget.cpp b/YUViewLib/src/ui/views/splitViewWidget.cpp
+index ff5723ba..4a29d723 100644
+--- a/YUViewLib/src/ui/views/splitViewWidget.cpp
++++ b/YUViewLib/src/ui/views/splitViewWidget.cpp
+@@ -38,6 +38,7 @@
+ #include <QInputDialog>
+ #include <QMessageBox>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QSettings>
+ #include <QTextDocument>
+