summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2022-11-06 22:18:38 +0100
committerAlexandre Bouvier2022-11-06 22:18:38 +0100
commit6bfe3686bd9b782729f41d473bcc59b0efd99c5b (patch)
treeba76107816bea8ccb319e82d15d1ef14ab86f292
parent2098f34920cbc19e981764ca5d73cd3148cb0ee7 (diff)
downloadaur-6bfe3686bd9b782729f41d473bcc59b0efd99c5b.tar.gz
update to mainline-0-1226
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD5
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4d54e17dcd1..5c8d415b23db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu
pkgdesc = Nintendo Switch emulator
- pkgver = mainline.0.1220
+ pkgver = mainline.0.1226
pkgrel = 1
url = https://yuzu-emu.org/
arch = x86_64
@@ -22,6 +22,7 @@ pkgbase = yuzu
makedepends = libva
makedepends = lz4>=1.8
makedepends = nlohmann-json>=3.8
+ makedepends = openssl
makedepends = opus>=1.3
makedepends = qt5-tools>=5.15
makedepends = sdl2>=2.0.18
@@ -33,7 +34,7 @@ pkgbase = yuzu
depends = enet>=1.3.13
depends = qt5-multimedia>=5.15
depends = qt5-webengine>=5.15
- source = yuzu-mainline::git+https://github.com/yuzu-emu/yuzu-mainline.git#tag=mainline-0-1220
+ source = yuzu-mainline::git+https://github.com/yuzu-emu/yuzu-mainline.git#tag=mainline-0-1226
source = yuzu-mbedtls::git+https://github.com/yuzu-emu/mbedtls.git
source = sirit::git+https://github.com/ReinUsesLisp/sirit.git
source = compatibility_list.json.xz
@@ -66,6 +67,7 @@ pkgname = yuzu
depends = libavcodec.so
depends = libavutil.so
depends = libboost_context.so
+ depends = libcrypto.so
depends = libcubeb.so
depends = libdynarmic.so
depends = libfmt.so
@@ -75,3 +77,4 @@ pkgname = yuzu
depends = libswscale.so
depends = libusb-1.0.so
depends = libva.so
+ depends = libzstd.so
diff --git a/PKGBUILD b/PKGBUILD
index e9aecb863bcc..cfb2bea025d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
pkgname=yuzu
-pkgver=mainline.0.1220
+pkgver=mainline.0.1226
pkgrel=1
pkgdesc="Nintendo Switch emulator"
arch=('x86_64')
@@ -28,6 +28,7 @@ makedepends=(
'libva'
'lz4>=1.8'
'nlohmann-json>=3.8'
+ 'openssl'
'opus>=1.3'
'qt5-tools>=5.15'
'sdl2>=2.0.18'
@@ -123,6 +124,7 @@ package() {
'libavcodec.so'
'libavutil.so'
'libboost_context.so'
+ 'libcrypto.so'
'libcubeb.so'
'libdynarmic.so'
'libfmt.so'
@@ -132,6 +134,7 @@ package() {
'libswscale.so'
'libusb-1.0.so'
'libva.so'
+ 'libzstd.so'
)
# shellcheck disable=SC2154
DESTDIR="$pkgdir" cmake --install build