summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2018-11-11 21:13:04 -0500
committerBrendan Szymanski2018-11-11 21:13:04 -0500
commit0b89b247ee6ae13feadf4159266626200612a1ae (patch)
treefbcaddd276c1e433f350f18643106bea486075d7
parent5ce42ee3e1c6d5fd65dc77fcafa281d657b1fb74 (diff)
downloadaur-0b89b247ee6ae13feadf4159266626200612a1ae.tar.gz
Merge QT frontend into this package and force build number in the title bar
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD52
2 files changed, 52 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e94b2f65b12..1c753a01abf4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-canary-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r8996.c9fd223ae
+ pkgver = r9492.2dcb93091
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-canary
arch = i686
@@ -14,10 +14,9 @@ pkgbase = yuzu-canary-git
depends = sdl2
depends = qt5-base
depends = qt5-multimedia
- optdepends = libxkbcommon-x11: for X11 support
+ depends = qt5-tools
+ depends = libxkbcommon-x11
optdepends = qt5-wayland: for Wayland support
- provides = yuzu-cmd
- conflicts = yuzu-cmd
source = yuzu::git+https://github.com/yuzu-emu/yuzu-canary
source = git+https://github.com/svn2github/inih
source = git+https://github.com/yuzu-emu/ext-boost
@@ -31,6 +30,14 @@ pkgbase = yuzu-canary-git
source = git+https://github.com/DarkLordZach/mbedtls
source = git+https://github.com/ogniK5377/opus
source = git+https://github.com/citra-emu/ext-soundtouch
+ source = git+https://github.com/citra-emu/ext-libressl-portable
+ source = git+https://github.com/discordapp/discord-rpc.git
+ source = git+https://github.com/google/googletest
+ source = git+https://github.com/arsenm/sanitizers-cmake
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b98a90e95663..f6a9ec0207f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,15 @@
_pkgname=yuzu
pkgname=$_pkgname-canary-git
-pkgver=r8996.c9fd223ae
+pkgver=r9492.2dcb93091
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
url="https://github.com/yuzu-emu/yuzu-canary"
license=('GPL2')
-depends=('shared-mime-info' 'desktop-file-utils' 'sdl2' 'qt5-base' 'qt5-multimedia')
+depends=('shared-mime-info' 'desktop-file-utils' 'sdl2' 'qt5-base' 'qt5-multimedia' 'qt5-tools' 'libxkbcommon-x11')
makedepends=('git' 'cmake' 'python')
-optdepends=('libxkbcommon-x11: for X11 support'
- 'qt5-wayland: for Wayland support')
-provides=('yuzu-cmd')
-conflicts=('yuzu-cmd')
+optdepends=('qt5-wayland: for Wayland support')
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-canary"
'git+https://github.com/svn2github/inih'
'git+https://github.com/yuzu-emu/ext-boost'
@@ -26,7 +23,12 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-canary"
'git+https://github.com/yuzu-emu/unicorn'
'git+https://github.com/DarkLordZach/mbedtls'
'git+https://github.com/ogniK5377/opus'
- 'git+https://github.com/citra-emu/ext-soundtouch')
+ 'git+https://github.com/citra-emu/ext-soundtouch'
+ 'git+https://github.com/citra-emu/ext-libressl-portable'
+ 'git+https://github.com/discordapp/discord-rpc.git'
+ # cubeb dependencies
+ 'git+https://github.com/google/googletest'
+ 'git+https://github.com/arsenm/sanitizers-cmake')
md5sums=('SKIP'
'SKIP'
'SKIP'
@@ -39,6 +41,10 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -48,7 +54,6 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- mkdir -p build
git submodule init
git config submodule.inih.url "$srcdir/inih"
@@ -63,15 +68,39 @@ prepare() {
git config submodule.mbedtls.url "$srcdir/mbedtls"
git config submodule.opus.url "$srcdir/opus"
git config submodule.soundtouch.url "$srcdir/ext-soundtouch"
+ git config submodule.libressl.url "$srcdir/ext-libressl-portable"
+ git config submodule.discord-rpc.url "$srcdir/discord-rpc"
+ git submodule update --init --recursive
+
+ cd externals/cubeb
+ git config submodule.googletest.url "$srcdir/googletest"
+ git config submodule.cmake/sanitizers-cmake.url "$srcdir/sanitizers-cmake"
+ git submodule update --init --recursive
+
+ cd ../dynarmic
+ git config submodule.externals/fmt.url "$srcdir/fmt"
+ git config submodule.externals/xbyak.url "$srcdir/xbyak"
git submodule update --init --recursive
}
build() {
- cd "$srcdir/$_pkgname/build"
+ # Trick the compiler into thinking we're building from a continuous
+ # integration tool so the build number is correctly shown in the title
+ cd "$srcdir/$_pkgname"
+ export CI=true
+ export TRAVIS=true
+ export TRAVIS_REPO_SLUG=yuzu-emu/yuzu-canary
+ export TRAVIS_TAG=$(git describe --tags)
+
+ mkdir -p build
+ cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DUSE_SYSTEM_CURL=1
+ -DYUZU_USE_BUNDLED_UNICORN=ON \
+ -DYUZU_ENABLE_COMPATIBILITY_REPORTING=ON \
+ -DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON \
+ -DUSE_DISCORD_PRESENCE=ON
make
}
@@ -81,5 +110,6 @@ check() {
}
package() {
- install -Dm755 "$srcdir/$_pkgname/build/bin/${_pkgname}-cmd" "$pkgdir/usr/bin/${_pkgname}-cmd"
+ cd "$srcdir/$_pkgname/build"
+ make DESTDIR="$pkgdir/" install
}