summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2018-08-22 06:17:54 -0400
committerBrendan Szymanski2018-08-22 06:17:54 -0400
commit8645ffbbc39869aff9ec2bd4d4172c720032a4a6 (patch)
treea46dec588503c41037949fbf0be89f027f0f271e
parent1a9ba37fee8078c939513c1c867b5bf6ed9a9537 (diff)
downloadaur-8645ffbbc39869aff9ec2bd4d4172c720032a4a6.tar.gz
Updated version number
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36b5358ea468..7ef30b6ee51d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-canary-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r8139.8c9a8123d
+ pkgver = r8185.c91add0ad
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-canary
arch = i686
@@ -8,14 +8,16 @@ pkgbase = yuzu-canary-git
license = GPL2
makedepends = git
makedepends = cmake
+ makedepends = python
depends = shared-mime-info
depends = desktop-file-utils
depends = sdl2
depends = qt5-base
depends = qt5-multimedia
- depends = mbedtls
optdepends = libxkbcommon-x11: for X11 support
optdepends = qt5-wayland: for Wayland support
+ provides = yuzu-cmd
+ conflicts = yuzu-cmd
source = yuzu::git+https://github.com/yuzu-emu/yuzu-canary
source = git+https://github.com/svn2github/inih
source = git+https://github.com/yuzu-emu/ext-boost
@@ -26,6 +28,7 @@ pkgbase = yuzu-canary-git
source = git+https://github.com/fmtlib/fmt
source = git+https://github.com/lz4/lz4
source = git+https://github.com/yuzu-emu/unicorn
+ source = git+https://github.com/DarkLordZach/mbedtls
source = git+https://github.com/ogniK5377/opus
md5sums = SKIP
md5sums = SKIP
@@ -38,6 +41,7 @@ pkgbase = yuzu-canary-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = yuzu-canary-git
diff --git a/PKGBUILD b/PKGBUILD
index 9ef4a010b479..b0544b83f7db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,18 @@
_pkgname=yuzu
pkgname=$_pkgname-canary-git
-pkgver=r8139.8c9a8123d
+pkgver=r8185.c91add0ad
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
url="https://github.com/yuzu-emu/yuzu-canary"
license=('GPL2')
-depends=('shared-mime-info' 'desktop-file-utils' 'sdl2' 'qt5-base' 'qt5-multimedia' 'mbedtls')
-makedepends=('git' 'cmake')
+depends=('shared-mime-info' 'desktop-file-utils' 'sdl2' 'qt5-base' 'qt5-multimedia')
+makedepends=('git' 'cmake' 'python')
optdepends=('libxkbcommon-x11: for X11 support'
'qt5-wayland: for Wayland support')
+provides=('yuzu-cmd')
+conflicts=('yuzu-cmd')
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-canary"
'git+https://github.com/svn2github/inih'
'git+https://github.com/yuzu-emu/ext-boost'
@@ -22,6 +24,7 @@ source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-canary"
'git+https://github.com/fmtlib/fmt'
'git+https://github.com/lz4/lz4'
'git+https://github.com/yuzu-emu/unicorn'
+ 'git+https://github.com/DarkLordZach/mbedtls'
'git+https://github.com/ogniK5377/opus')
md5sums=('SKIP'
'SKIP'
@@ -33,6 +36,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -54,6 +58,7 @@ prepare() {
git config submodule.fmt.url "$srcdir/fmt"
git config submodule.lz4.url "$srcdir/lz4"
git config submodule.unicorn.url "$srcdir/unicorn"
+ git config submodule.mbedtls.url "$srcdir/mbedtls"
git config submodule.opus.url "$srcdir/opus"
git submodule update --init --recursive
}