summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2019-06-20 21:55:35 -0400
committerBrendan Szymanski2019-06-20 21:55:35 -0400
commit8ffcca228d65bb6395509fc81b05165683ad7d05 (patch)
tree67dd54e0fc8254f3d98e383efa0345dd4c09ad96
parentfe1e36321c755cf571f4fbd91a755fc54aa9fd09 (diff)
downloadaur-8ffcca228d65bb6395509fc81b05165683ad7d05.tar.gz
Add a workaround for a build error in the fmt library
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD11
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3a3acce53ad..a25d5c1e16ac 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-canary-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r11855.d070fd91a
+ pkgver = r11874.dfac63de3
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-canary
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index b248c3d55248..15292b3a197a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname='yuzu-canary'
pkgname="$_pkgname-git"
-pkgver=r11855.d070fd91a
+pkgver=r11874.dfac63de3
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
@@ -47,12 +47,15 @@ build() {
export TRAVIS_REPO_SLUG=yuzu-emu/yuzu-canary
export TRAVIS_TAG=$(git describe --tags)
- mkdir -p build
- cd build
+ # Hopefully temporary fix for a compilation error involving fmt
+ CXXFLAGS+=" -DFMT_USE_USER_DEFINED_LITERALS=0"
+
+ mkdir -p build && cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
-DYUZU_USE_BUNDLED_UNICORN=ON \
+ -DYUZU_USE_QT_WEB_ENGINE=ON \
+ -DCMAKE_BUILD_TYPE=Release \
-DYUZU_ENABLE_COMPATIBILITY_REPORTING=ON \
-DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON \
-DUSE_DISCORD_PRESENCE=ON