summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2019-06-18 00:37:17 -0400
committerBrendan Szymanski2019-06-18 00:37:17 -0400
commitfe1e36321c755cf571f4fbd91a755fc54aa9fd09 (patch)
tree1b4874f24f6519e3fd3f0eaef9148f8cf8c17ff4
parent8f105170b4459cb7081c8a0470a25f7fd12473ae (diff)
downloadaur-fe1e36321c755cf571f4fbd91a755fc54aa9fd09.tar.gz
Provide conflict warnings, remove libzip and zlib workaround, and other fixes
-rwxr-xr-x.SRCINFO7
-rwxr-xr-xPKGBUILD14
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0cfa00f157b..c3a3acce53ad 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-canary-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r11849.7abd66d92
+ pkgver = r11855.d070fd91a
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-canary
arch = i686
@@ -19,7 +19,10 @@ pkgbase = yuzu-canary-git
depends = libzip
depends = zlib
optdepends = qt5-wayland: for Wayland support
- source = yuzu::git+https://github.com/yuzu-emu/yuzu-canary
+ provides = yuzu
+ provides = yuzu-cmd
+ conflicts = yuzu-git
+ source = yuzu-canary::git+https://github.com/yuzu-emu/yuzu-canary
md5sums = SKIP
pkgname = yuzu-canary-git
diff --git a/PKGBUILD b/PKGBUILD
index e373c9869700..b248c3d55248 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
-# Maintainer: Brendan Szymanski <brendan.szymanski1@gmail.com>
+# Maintainer: bscubed <bscubed@pm.me>
-_pkgname=yuzu
-pkgname=$_pkgname-canary-git
-pkgver=r11849.7abd66d92
+_pkgname='yuzu-canary'
+pkgname="$_pkgname-git"
+pkgver=r11855.d070fd91a
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
url="https://github.com/yuzu-emu/yuzu-canary"
license=('GPL2')
+provides=('yuzu' 'yuzu-cmd')
+conflicts=('yuzu-git')
depends=('shared-mime-info'
'desktop-file-utils'
'sdl2'
@@ -66,8 +68,4 @@ package() {
cd "$srcdir/$_pkgname/build"
make DESTDIR="$pkgdir/" install
-
- # Temporary fix until yuzu fixes the zlib and libzip patch they pushed yesterday
- cd "$pkgdir/usr"
- rm -rf include lib lib64 share/man share/pkgconfig
}