summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorheavysink2020-11-21 15:46:57 -0500
committerheavysink2020-11-21 15:46:57 -0500
commit41070e2051e63d273fad995c34dc454bfa0df796 (patch)
treebd8a4a15cf1d20e626458375ec5c8f75ee40d223
downloadaur-41070e2051e63d273fad995c34dc454bfa0df796.tar.gz
Initial commit
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD74
2 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9fb8f9fe0bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,52 @@
+pkgbase = yuzu-early-access-kiku233-git
+ pkgdesc = An experimental open-source Nintendo Switch emulator/debugger (early access with Chinese translation)
+ pkgver = 1138.r0.ga8f198c7e
+ pkgrel = 1
+ url = https://github.com/yuzu-emu/yuzu-mainline
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = python2
+ makedepends = graphviz
+ makedepends = doxygen
+ makedepends = clang
+ makedepends = boost
+ makedepends = catch2
+ makedepends = nlohmann-json
+ makedepends = rapidjson
+ makedepends = desktop-file-utils
+ makedepends = conan
+ depends = shared-mime-info
+ depends = hicolor-icon-theme
+ depends = sdl2
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = qt5-tools
+ depends = libxkbcommon-x11
+ depends = ffmpeg
+ depends = fmt
+ depends = libzip
+ depends = opus
+ depends = libfdk-aac
+ depends = lz4
+ depends = mbedtls
+ depends = openssl
+ depends = zstd
+ optdepends = qt5-wayland: for Wayland support
+ provides = yuzu
+ provides = yuzu-early-access
+ provides = yuzu-early-access-git
+ conflicts = yuzu-canary-git
+ conflicts = yuzu-master-git
+ conflicts = yuzu-mainline-git
+ conflicts = yuzu-git
+ conflicts = yuzu-ea-bin
+ replaces = yuzu-canary-git
+ source = yuzu::git+https://github.com/kiku233/yuzu-early-access.git
+ md5sums = SKIP
+
+pkgname = yuzu-early-access-kiku233-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b4e31a7c48f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: Heavysink <winstonwu91 at gmail>
+
+_pkgname=yuzu
+pkgname=$_pkgname-early-access-kiku233-git
+pkgver=1138.r0.ga8f198c7e
+pkgrel=1
+pkgdesc="An experimental open-source Nintendo Switch emulator/debugger (early access with Chinese translation)"
+arch=('i686' 'x86_64')
+url="https://github.com/yuzu-emu/yuzu-mainline"
+license=('GPL2')
+depends=('shared-mime-info' 'hicolor-icon-theme' 'sdl2' 'qt5-base' 'qt5-multimedia' 'qt5-tools' 'libxkbcommon-x11' 'ffmpeg' 'fmt' 'libzip' 'opus' 'libfdk-aac' 'lz4' 'mbedtls' 'openssl' 'zstd')
+makedepends=('git' 'cmake' 'ninja' 'python2' 'graphviz' 'doxygen' 'clang' 'boost' 'catch2' 'nlohmann-json' 'rapidjson' 'desktop-file-utils' 'conan')
+optdepends=('qt5-wayland: for Wayland support')
+provides=('yuzu' 'yuzu-early-access' 'yuzu-early-access-git')
+conflicts=('yuzu-canary-git' 'yuzu-master-git' 'yuzu-mainline-git' 'yuzu-git' 'yuzu-ea-bin')
+replaces=('yuzu-canary-git')
+source=("$_pkgname::git+https://github.com/kiku233/yuzu-early-access.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/mainline-0-//g;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+
+ git submodule init
+ git submodule update --init --recursive
+
+ #sed -i 's/Werror=reorder/Wno-reorder/g' src/CMakeLists.txt
+ #sed -i 's/Werror=conversion/Wno-conversion/g' src/video_core/CMakeLists.txt
+}
+
+build() {
+ # Trick the compiler into thinking we're building from a continuous
+ # integration tool so the build number is correctly shown in the title
+ cd "$srcdir/$_pkgname"
+ export CI=true
+ export TRAVIS=true
+ export TRAVIS_REPO_SLUG=yuzu-emu/yuzu-mainline
+ export TRAVIS_TAG=$(git describe --tags)
+
+ # Hopefully temporary fix for a compilation error involving fmt
+ #CXXFLAGS+=" -DFMT_USE_USER_DEFINED_LITERALS=0"
+
+ # Flag to disable pre-compiled headers so boost can build properly
+ # CXXFLAGS+=" -DENABLE_PRECOMPILED_HEADERS=OFF"
+
+ # Flag to fix SDL exceptions occurring in some users' builds
+ #CXXFLAGS+=" -I/usr/include/SDL2 -D_REENTRANT -pthread -lSDL2"
+
+ #CXXFLAGS+=" -I/usr/include/libusb-1.0"
+
+ mkdir -p build && cd build
+ cmake -GNinja .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DYUZU_ENABLE_COMPATIBILITY_REPORTING=ON \
+ -DYUZU_USE_BUNDLED_UNICORN=ON \
+ -DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON \
+ -DUSE_DISCORD_PRESENCE=ON
+ ninja
+}
+
+check() {
+ cd "$srcdir/$_pkgname/build"
+ ninja test
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ DESTDIR="$pkgdir" ninja install
+}