summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-12-04 19:34:28 +0800
committerlilac2020-12-04 19:34:28 +0800
commitcaad70b6ecf9daf6e2ae4d8272a6d1d9ed748de0 (patch)
treeb0e5c68756664f53a7a107d91376abe6049bb462
parent7c4816ab38f7f4e5a8115e8b8ec8f89bd7363b9b (diff)
downloadaur-caad70b6ecf9daf6e2ae4d8272a6d1d9ed748de0.tar.gz
[lilac] updated to 1152.r7.gcb8c83936-2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b75eb9b94d3a..f9e2891b8020 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-early-access-kiku233-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger (early access with Chinese translation)
- pkgver = 1152.r1.g9a905b57d
+ pkgver = 1152.r7.gcb8c83936
pkgrel = 2
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
@@ -19,7 +19,7 @@ pkgbase = yuzu-early-access-kiku233-git
makedepends = nlohmann-json
makedepends = rapidjson
makedepends = desktop-file-utils
- makedepends = conan
+ depends = boost-libs
depends = shared-mime-info
depends = hicolor-icon-theme
depends = sdl2
diff --git a/PKGBUILD b/PKGBUILD
index 9a2f8b92fd75..40ad85decb32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
_pkgname=yuzu
pkgname=$_pkgname-early-access-kiku233-git
-pkgver=1152.r1.g9a905b57d
+pkgver=1152.r7.gcb8c83936
pkgrel=2
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger (early access with Chinese translation)"
arch=('i686' 'x86_64')
url="https://github.com/yuzu-emu/yuzu-mainline"
license=('GPL2')
-depends=('shared-mime-info' 'hicolor-icon-theme' 'sdl2' 'qt5-base' 'qt5-multimedia' 'qt5-tools' 'libxkbcommon-x11' 'ffmpeg' 'fmt' 'libzip' 'opus' 'libfdk-aac' 'lz4' 'mbedtls' 'openssl' 'zstd')
-makedepends=('git' 'cmake' 'glslang' 'ninja' 'python2' 'graphviz' 'doxygen' 'clang' 'boost' 'catch2' 'nlohmann-json' 'rapidjson' 'desktop-file-utils' 'conan')
+depends=('boost-libs' 'shared-mime-info' 'hicolor-icon-theme' 'sdl2' 'qt5-base' 'qt5-multimedia' 'qt5-tools' 'libxkbcommon-x11' 'ffmpeg' 'fmt' 'libzip' 'opus' 'libfdk-aac' 'lz4' 'mbedtls' 'openssl' 'zstd')
+makedepends=('git' 'cmake' 'glslang' 'ninja' 'python2' 'graphviz' 'doxygen' 'clang' 'boost' 'catch2' 'nlohmann-json' 'rapidjson' 'desktop-file-utils')
optdepends=('qt5-wayland: for Wayland support')
provides=('yuzu' 'yuzu-early-access' 'yuzu-early-access-git')
conflicts=('yuzu-canary-git' 'yuzu-master-git' 'yuzu-mainline-git' 'yuzu-git' 'yuzu-ea-bin')
@@ -25,9 +25,9 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- git submodule init
git submodule update --init --recursive
-
+
+ sed -i 's/1.73/1.72/g' CMakeLists.txt
#sed -i 's/Werror=reorder/Wno-reorder/g' src/CMakeLists.txt
#sed -i 's/Werror=conversion/Wno-conversion/g' src/video_core/CMakeLists.txt
}