summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZion Nimchuk2018-08-06 15:25:50 -0700
committerZion Nimchuk2018-08-06 15:25:50 -0700
commit4fdd3b6f35514961249589a14a782f13b0caebfa (patch)
treeee904ec4c26694240439d3866e17fa3b0c4293bd
parent6d221ef4855783b27b835a46c1e332cbbf7cb211 (diff)
downloadaur-4fdd3b6f35514961249589a14a782f13b0caebfa.tar.gz
fix issues with mbedtls
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15065346722a..d017a978d845 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-git
pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r7580.29f31356
+ pkgver = r7653.83ef37ca
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu/
arch = i686
@@ -23,6 +23,7 @@ pkgbase = yuzu-git
source = git+https://github.com/yuzu-emu/unicorn
source = git+https://github.com/lz4/lz4
source = git+https://github.com/ogniK5377/opus
+ source = git+https://github.com/DarkLordZach/mbedtls
source = git+https://github.com/kinetiknz/cubeb
source = git+https://github.com/arsenm/sanitizers-cmake
md5sums = SKIP
@@ -37,6 +38,7 @@ pkgbase = yuzu-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = yuzu-git
depends = sdl2
diff --git a/PKGBUILD b/PKGBUILD
index 55ca715f7840..b0208772c891 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgbase='yuzu'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r7580.29f31356
+pkgver=r7653.83ef37ca
pkgrel=1
pkgdesc="An experimental open-source Nintendo Switch emulator/debugger"
arch=('i686' 'x86_64')
@@ -19,6 +19,7 @@ source=("$_pkgbase::git+https://github.com/yuzu-emu/yuzu"
'git+https://github.com/yuzu-emu/unicorn'
'git+https://github.com/lz4/lz4'
'git+https://github.com/ogniK5377/opus'
+ 'git+https://github.com/DarkLordZach/mbedtls'
'git+https://github.com/kinetiknz/cubeb'
# cubeb submodule dependencies
'git+https://github.com/arsenm/sanitizers-cmake')
@@ -33,6 +34,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -53,6 +55,7 @@ prepare() {
git config submodule.inih.url "$srcdir/inih"
git config submodule.unicorn.url "$srcdir/unicorn"
git config submodule.opus.url "$srcdir/opus"
+ git config submodule.mbedtls.url "$srcdir/mbedtls"
git config submodule.cubeb.url "$srcdir/cubeb"
git submodule update
@@ -66,7 +69,8 @@ build() {
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DBUILD_TESTS=False
+ -DBUILD_TESTS=False \
+ -DINSTALL_MBEDTLS_HEADERS=False
make
}
@@ -91,6 +95,8 @@ package_yuzu-qt-git() {
# screw cubeb cmake even more
rm -r "$pkgdir/usr/lib64"
rm -r "$pkgdir/usr/include"
+ # Yay mbedtls joins the ring
+ rm -r "$pkgdir/usr/lib"
rm "$pkgdir/usr/bin/${_pkgbase}-cmd"
}