summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Szymanski2021-08-25 22:00:45 -0400
committerBrendan Szymanski2021-08-25 22:00:45 -0400
commitc8661ae69aae02a73f03e691193c44980c170944 (patch)
treed3b53b3a9533a0ee5ae0a3894693305d49a27a21
parente261f6caa8715eccd5e1ae46ff35dbd16d338661 (diff)
downloadaur-c8661ae69aae02a73f03e691193c44980c170944.tar.gz
Added compatability list review, updated dependencies to reduce build time
-rwxr-xr-x.SRCINFO12
-rwxr-xr-xPKGBUILD31
2 files changed, 26 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15f3da718052..95677a2071e8 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,28 @@
pkgbase = yuzu-git
- pkgdesc = An experimental open-source Nintendo Switch emulator/debugger
- pkgver = r18480.e7c30f33f
+ pkgdesc = An experimental open-source emulator for the Nintendo Switch
+ pkgver = r19504.3843995ce
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu
arch = i686
arch = x86_64
license = GPL2
+ makedepends = boost
makedepends = catch2
makedepends = cmake
makedepends = fmt
+ makedepends = ffmpeg
makedepends = git
+ makedepends = ninja
makedepends = nlohmann-json
depends = desktop-file-utils
depends = glslang
- depends = libxkbcommon-x11
depends = libfdk-aac
+ depends = libxkbcommon-x11
+ depends = libzip
depends = lz4
+ depends = mbedtls
depends = openssl
+ depends = opus
depends = qt5-base
depends = qt5-multimedia
depends = qt5-tools
diff --git a/PKGBUILD b/PKGBUILD
index e7a824c3d32c..40929a07840b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Zion Nimchuk <zionnimchuk@gmail.com>
-# Co-maintainer: Brendan Szymanski <bscubed@pm.me>
+# Co-maintainer: Brendan Szymanski <hello@bscubed.dev>
_pkgname=yuzu
pkgname=$_pkgname-git
-pkgver=r18480.e7c30f33f
+pkgver=r19504.3843995ce
pkgrel=1
-pkgdesc='An experimental open-source Nintendo Switch emulator/debugger'
+pkgdesc='An experimental open-source emulator for the Nintendo Switch'
arch=('i686' 'x86_64')
url='https://github.com/yuzu-emu/yuzu'
license=('GPL2')
@@ -13,10 +13,13 @@ provides=('yuzu' 'yuzu-cmd')
conflicts=('yuzu-mainline-git' 'yuzu-canary-git')
depends=('desktop-file-utils'
'glslang'
- 'libxkbcommon-x11'
'libfdk-aac'
+ 'libxkbcommon-x11'
+ 'libzip'
'lz4'
+ 'mbedtls'
'openssl'
+ 'opus'
'qt5-base'
'qt5-multimedia'
'qt5-tools'
@@ -26,7 +29,14 @@ depends=('desktop-file-utils'
'shared-mime-info'
'zlib'
'zstd')
-makedepends=('catch2' 'cmake' 'fmt' 'git' 'nlohmann-json')
+makedepends=('boost'
+ 'catch2'
+ 'cmake'
+ 'fmt'
+ 'ffmpeg'
+ 'git'
+ 'ninja'
+ 'nlohmann-json')
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu"
'git+https://github.com/benhoyt/inih.git'
'git+https://github.com/kinetiknz/cubeb.git'
@@ -102,13 +112,6 @@ prepare() {
build() {
cd "$srcdir/$_pkgname"
- # Trick the compiler into thinking we're building from a continuous
- # integration tool so the build number is correctly shown in the title
- export CI=true
- export TRAVIS=true
- export TRAVIS_REPO_SLUG=yuzu-emu/yuzu-mainline
- export TRAVIS_TAG=$(git describe --tags)
-
if [[ -d build ]]; then
rm -rf build
fi
@@ -117,9 +120,9 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DENABLE_QT_TRANSLATION=ON \
- -DYUZU_USE_BUNDLED_BOOST=ON \
-DYUZU_USE_QT_WEB_ENGINE=ON \
- -DUSE_DISCORD_PRESENCE=ON
+ -DUSE_DISCORD_PRESENCE=ON \
+ -DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON
make
}