summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2022-10-03 13:31:00 -0500
committerHurricanePootis2022-10-03 13:31:00 -0500
commitafe80c416ebff04e368306bbc092c966fd4d5589 (patch)
tree2247fe722317fbc117e94715e37c71ada20928ea
parent4ecfbd153a3241f5e7faf187f55c363290842354 (diff)
downloadaur-afe80c416ebff04e368306bbc092c966fd4d5589.tar.gz
Add enet as a dependency and external module
-rwxr-xr-x.SRCINFO5
-rwxr-xr-xPKGBUILD10
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fab93d5845bf..d76a633b7e4c 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = r22061.40d581c0f
+ pkgver = r22095.61399de5d
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
@@ -34,11 +34,13 @@ pkgbase = yuzu-mainline-git
depends = shared-mime-info
depends = zlib
depends = zstd
+ depends = enet
provides = yuzu
provides = yuzu-cmd
conflicts = yuzu-git
conflicts = yuzu-canary-git
source = yuzu::git+https://github.com/yuzu-emu/yuzu-mainline
+ source = git+https://github.com/lsalzman/enet.git
source = git+https://github.com/benhoyt/inih.git
source = git+https://github.com/kinetiknz/cubeb.git
source = git+https://github.com/MerryMage/dynarmic.git
@@ -78,5 +80,6 @@ pkgbase = yuzu-mainline-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = yuzu-mainline-git
diff --git a/PKGBUILD b/PKGBUILD
index 00370c5e5a4c..92d8e9de4da8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Brendan Szymanski <hello@bscubed.dev>
+# Co-Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=r22061.40d581c0f
+pkgver=r22095.61399de5d
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
@@ -28,7 +29,8 @@ depends=('desktop-file-utils'
'sdl2'
'shared-mime-info'
'zlib'
- 'zstd')
+ 'zstd'
+ 'enet')
makedepends=('boost'
'catch2'
'clang'
@@ -39,6 +41,7 @@ makedepends=('boost'
'nlohmann-json'
'robin-map')
source=("$_pkgname::git+https://github.com/yuzu-emu/yuzu-mainline"
+ 'git+https://github.com/lsalzman/enet.git'
'git+https://github.com/benhoyt/inih.git'
'git+https://github.com/kinetiknz/cubeb.git'
'git+https://github.com/MerryMage/dynarmic.git'
@@ -79,6 +82,7 @@ md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -89,7 +93,7 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- for submodule in {inih,cubeb,dynarmic,libressl,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt};
+ for submodule in {inih,cubeb,dynarmic,libressl,libusb,discord-rpc,Vulkan-Headers,sirit,mbedtls,xbyak,opus,ffmpeg,SDL,cpp-httplib,vcpkg,cpp-jwt,enet};
do
git config --file=.gitmodules submodule.$submodule.url "$srcdir/${submodule}"
done