summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-02-13 15:52:28 -0600
committerHurricanePootis2023-02-13 15:52:28 -0600
commitee90682b52d648807273bd85ada52e7948b507e8 (patch)
tree38defb0ef4172f14b2aae431dc0ad36510407acd
parent35ca594ee2a63f1894dacf2a5ba8a1d5d9503802 (diff)
downloadaur-ee90682b52d648807273bd85ada52e7948b507e8.tar.gz
Fix conflicts() and add boost-libs
-rwxr-xr-x.SRCINFO4
-rwxr-xr-xPKGBUILD7
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9364090a8181..abc59916ef7f 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yuzu-mainline-git
pkgdesc = An experimental open-source emulator for the Nintendo Switch (newest features)
- pkgver = r23195.d60e3dead
+ pkgver = r23233.cd3a0a737
pkgrel = 1
url = https://github.com/yuzu-emu/yuzu-mainline
arch = i686
@@ -36,10 +36,12 @@ pkgbase = yuzu-mainline-git
depends = zlib
depends = zstd
depends = enet
+ depends = boost-libs
provides = yuzu
provides = yuzu-cmd
conflicts = yuzu-git
conflicts = yuzu-canary-git
+ conflicts = yuzu
options = !lto
source = yuzu::git+https://github.com/yuzu-emu/yuzu-mainline
source = git+https://github.com/lsalzman/enet.git
diff --git a/PKGBUILD b/PKGBUILD
index 248424ea1652..38ebbed63269 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
_pkgname=yuzu
pkgname=$_pkgname-mainline-git
-pkgver=r23195.d60e3dead
+pkgver=r23233.cd3a0a737
pkgrel=1
pkgdesc='An experimental open-source emulator for the Nintendo Switch (newest features)'
arch=('i686' 'x86_64')
url='https://github.com/yuzu-emu/yuzu-mainline'
license=('GPL2')
provides=('yuzu' 'yuzu-cmd')
-conflicts=('yuzu-git' 'yuzu-canary-git')
+conflicts=('yuzu-git' 'yuzu-canary-git' 'yuzu')
options=("!lto") #ThinLTO is already set
depends=('desktop-file-utils'
'fmt'
@@ -31,7 +31,8 @@ depends=('desktop-file-utils'
'shared-mime-info'
'zlib'
'zstd'
- 'enet')
+ 'enet'
+ 'boost-libs')
makedepends=('boost'
'llvm'
'catch2'