summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPrayz Jomba2021-10-27 16:20:03 +0300
committerPrayz Jomba2021-10-27 16:20:03 +0300
commitbbcad45044cfc02936cbd45b9dd59a04c865dfe0 (patch)
tree786d4612fa2a17495cd4a7a4f439736e33d28d70
downloadaur-bbcad45044cfc02936cbd45b9dd59a04c865dfe0.tar.gz
initial push
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f8daebca3ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = ywatch-git
+ pkgdesc = Watch youtube videos with mpv while saving the video to disk.
+ pkgver = 0.6.3
+ pkgrel = 1
+ url = https://github.com/prayzjomba/ywatch.git
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = make
+ makedepends = python-setuptools
+ depends = youtube-dl
+ depends = xclip
+ depends = mpv
+ depends = python-rich
+ depends = python-pyperclip
+ depends = python-func-timeout
+ provides = yw
+ source = ywatch-git::git+https://github.com/prayzjomba/ywatch.git#branch=0.6.3
+ md5sums = SKIP
+
+pkgname = ywatch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..cd54a7a7da42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Prayz Jomba <prayzjomba@protonmail.com>
+pkgname=ywatch-git
+pkgver=0.6.3
+pkgrel=1
+pkgdesc="Watch youtube videos with mpv while saving the video to disk."
+arch=(any)
+url="https://github.com/prayzjomba/ywatch.git"
+license=('GPL')
+depends=('youtube-dl' 'xclip' 'mpv' 'python-rich' 'python-pyperclip' 'python-func-timeout')
+makedepends=('git' 'make' 'python-setuptools')
+provides=(yw)
+install=
+changelog=
+source=("$pkgname"::"git+$url#branch=$pkgver")
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$pkgname"
+ printf "0.6.3.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ cd "$pkgname"
+ python setup.py build
+}
+
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
+}