summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-06-23 01:38:16 -0700
committerJohn ShaggyTwoDope Jenkins2015-06-23 01:38:16 -0700
commitd62802b8c19926e7f49530455d47fbe91c89c825 (patch)
tree8c8023f4b92b0aacf24b087832fa6f4cf8f7dc77
downloadaur-d62802b8c19926e7f49530455d47fbe91c89c825.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07221bfa9364
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = z-git
+ pkgdesc = z keeps track of where you've been and provides a convenient way to jump to directory that you actually use (git version)
+ pkgver = 1.8.14.g855ca29
+ pkgrel = 1
+ url = http://github.com/rupa/z
+ arch = any
+ license = WTFPL
+ makedepends = git
+ depends = sh
+ source = git://github.com/rupa/z
+ md5sums = SKIP
+
+pkgname = z-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fa20f73309a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: John Jekins twodopeshaggy@gmail.com
+# Contributor: Mark Cornick <mcornick@mcornick.com>
+# Contributor: Patrick Palka <patrick@parcs.ath.cx>
+
+_pkgname=z
+pkgname=z-git
+pkgver=1.8.14.g855ca29
+pkgrel=1
+pkgdesc="z keeps track of where you've been and provides a convenient \
+way to jump to directory that you actually use (git version)"
+url="http://github.com/rupa/z"
+arch=('any')
+license=('WTFPL')
+depends=('sh')
+makedepends=('git')
+source=(git://github.com/rupa/z)
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd $_pkgname
+ git describe --always | sed -e 's|-|.|g' -e 's|v||'
+}
+
+package() {
+ cd $_pkgname
+
+ install -vDm755 z.sh "$pkgdir/usr/lib/z.sh"
+ install -vDm644 z.1 "$pkgdir/usr/share/man/man1/z.1"
+}