summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Bolka2019-02-13 18:42:29 +0100
committerAndreas Bolka2019-02-13 18:51:26 +0100
commit176c1a457b87c944a98de789f27d8ce21cbc4955 (patch)
tree6d5a98404db95ba94f68a685fcc965e7ea8f27e3
downloadaur-z.lua-git.tar.gz
Initial package upload
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ddd7ead5eeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = z.lua-git
+ pkgdesc = A command line tool which helps you navigate faster by learning your habits
+ pkgver = 1.4.4.gcf45449
+ pkgrel = 1
+ url = https://github.com/skywind3000/z.lua
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = lua
+ provides = z.lua
+ conflicts = z.lua
+ source = z.lua-git::git+https://github.com/skywind3000/z.lua
+ sha256sums = SKIP
+
+pkgname = z.lua-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11c34e9716dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andreas Bolka <a AT bolka DOT at>
+
+pkgname=z.lua-git
+pkgver=1.4.4.gcf45449
+pkgrel=1
+pkgdesc='A command line tool which helps you navigate faster by learning your habits'
+arch=('any')
+url='https://github.com/skywind3000/z.lua'
+license=('MIT')
+depends=('lua')
+makedepends=('git')
+provides=('z.lua')
+conflicts=('z.lua')
+source=("$pkgname::git+https://github.com/skywind3000/z.lua")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ local GITID=$(git rev-parse --short HEAD)
+ echo "${pkgver%\.g*}.g$GITID"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -D -t "$pkgdir/usr/share/z.lua/" z.lua
+ install -Dm644 -t "$pkgdir/usr/share/licenses/${pkgname%-*}/" LICENSE
+}