summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorslimb2020-12-01 22:33:18 -0800
committerslmb32020-12-01 22:36:35 -0800
commitd7237e66bf658f796cda72c13b799f106c8324c3 (patch)
treee0683735e6cbfb16252819459720f408b078c076
downloadaur-d7237e66bf658f796cda72c13b799f106c8324c3.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3a4e66a2f8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = z3ntu-razer_test-git
+ pkgdesc = A work-in-progress replacement for OpenRazer
+ pkgver = r152.7d866a6
+ pkgrel = 1
+ url = https://github.com/z3ntu/razer_test
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = hidapi
+ depends = systemd-libs
+ provides = razer_test
+ conflicts = razer_test
+ source = git+https://github.com/z3ntu/razer_test.git
+ sha512sums = SKIP
+
+pkgname = z3ntu-razer_test-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f9e4fd6c298
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: slmb3
+
+_pkgname=razer_test
+pkgname=z3ntu-razer_test-git
+pkgver=r152.7d866a6
+pkgrel=1
+pkgdesc="A work-in-progress replacement for OpenRazer"
+arch=('x86_64')
+url="https://github.com/z3ntu/razer_test"
+license=('GPL3')
+depends=('qt5-base' 'hidapi' 'systemd-libs')
+makedepends=('git' 'meson' 'qt5-tools')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=('git+https://github.com/z3ntu/razer_test.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ echo "$pkgdir"
+ arch-meson "$_pkgname" build
+ ninja -C build
+}
+
+package() {
+ echo "$pkgdir"
+ DESTDIR="$pkgdir" meson install -C build
+}